Bug 129119 - xmms packages are out of date
xmms packages are out of date
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: xmms (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-04 02:45 EDT by Landon Curt Noll
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 11:31:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Landon Curt Noll 2004-08-04 02:45:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
RHEL has been shipping a old version of xmms.  Current versions
in use (and working well) are based on 1.2.10 since 23 Feb 2004:

    xmms-gl-1.2.10-1
    xmms-devel-1.2.10-1
    xmms-vorbis-1.2.10-1
    xmms-esd-1.2.10-1
    xmms-1.2.10-1
    xmms-mikmod-1.2.10-1

XMMS 1.2.10 has been released. This release fixes a bug that could
cause programs that control xmms to abort, and some other minor issues.




Version-Release number of selected component (if applicable):
xmms-1.2.7-22.1.p

How reproducible:
Always

Steps to Reproduce:
1.rpm -q -a | grep xmms
2.
3.
    

Actual Results:  RH is shipping version 1.2.7 xmms code.

Expected Results:  RH should be shipping version 1.2.10 xmms code.

Additional info:

There are audio applications that require more modern version of xmms.
It would be nice if we didn't have to exclude xmms packages from
our up2date downloads.
Comment 1 Colin Walters 2004-08-04 14:46:04 EDT
What programs control XMMS, and under what conditions do they abort?
Comment 2 Landon Curt Noll 2004-08-04 19:08:19 EDT
See the http://www.xmms.org web site, and see the
http://www.xmms.org/next_version.php page for a
list of changes since 1.2.7.

The madman music manager requires xmms-1.2.10.
There as another package that needed xmms > 1.2.7
whose name I don't recall right now ... I can hunt
that down if it is important.
Comment 3 Colin Walters 2004-08-04 21:29:39 EDT
madman?  We don't ship that in RHEL as far as I know.  I am a bit
unsure about just upgrading to a new version to support unrelated
software.  Were there any issues besides the madman one you were
experiencing?
Comment 4 Landon Curt Noll 2004-08-05 05:34:10 EDT
Well ignoring the other package (which was a non-RH package),
I did discover some problems with the old xmms:

I fould that moving forward / seeking in files with xing headers
that did not have a proper file length coded in them crashed xmms.
I was told: this was fixed in 1.2.10:

        * Input/mpg123/mpg123.c (decode_loop): Fix seeking in some
          files with xing headers that miss file length.

Also on startup, xmms would sometimes move all windows to the current
desktop.  I was told this was fixed in 1.2.10:

        * xmms/hints.c (net_wm_set_desktop): Fix a bug where we at
          startup would move all windows to the current desktop.

I also discovered that in certain cases, a truncated file
would crash xmms.  I was told this was fixed in 1.2.10:

        * libxmms/xmmsctrl.c (read_all): An early eof was handled
          inproperly causing crashes.
Comment 5 Colin Walters 2004-10-26 11:31:00 EDT
Ok, I'm going over my bugs, and to be absolutely honest with you, I don't think
I'll be doing an xmms update for RHEL3.  The advantages you've listed above have
to be weighed against the fact that we'd be going to an entirely new upstream
version, versus one that we've tested with the rest of the software in RHEL3. 
Having tracked down some evil xmms bugs due to interaction with other libraries
like arts before, I can say that it's not always just a simple update.

We will be shipping the newer version in RHEL4 of course.  

Note You need to log in before you can comment on or make changes to this bug.