Bug 1291208 - Regular files are listed as 'T' files on nfs mount
Regular files are listed as 'T' files on nfs mount
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Jiffin
bugs@gluster.org
: Triaged
Depends On: 1289423
Blocks: 1291212
  Show dependency treegraph
 
Reported: 2015-12-14 05:05 EST by Jiffin
Modified: 2016-04-19 03:51 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1289423
: 1291212 (view as bug list)
Environment:
Last Closed: 2016-02-15 14:23:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-17 04:10:03 EST
REVIEW: http://review.gluster.org/12989 (nfs : Inform client to perform extra GETATTR call for 'T' files) posted (#2) for review on release-3.7 by Niels de Vos (ndevos@redhat.com)
Comment 2 Vijay Bellur 2015-12-17 05:28:27 EST
REVIEW: http://review.gluster.org/12989 (nfs : Inform client to perform extra GETATTR call for 'T' files) posted (#3) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 3 Vijay Bellur 2015-12-17 09:34:03 EST
COMMIT: http://review.gluster.org/12989 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit e9bb9f018f14f7d32c2ff4cc33df3a114a6f376b
Author: Jiffin Tony Thottan <jthottan@gmail.com>
Date:   Mon Dec 14 15:29:21 2015 +0530

    nfs : Inform client to perform extra GETATTR call for 'T' files
    
    Due to the changes from http://review.gluster.org/#/c/12722/,
    for tier volume the readirp will be send only to cold subvol,
    therefore the resulting list may contain 'T' files. For those
    files, by performing additional getattr call will populate the
    attributes correctly. This check should be based on inode value
    passed from the readdirp(both T files and directory have NULL
    value) and skip directory in the same.
    
    Cherry picked from commit 5e36564754e2d83a7666066f4da7f148960a5694:
    > Change-Id: Ieb6724b05301cdbf0a0ef15ad9db51014faa0457
    > BUG: 1291212
    > Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    > Reviewed-on: http://review.gluster.org/12960
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: soumya k <skoduri@redhat.com>
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    
    Change-Id: Ida82b6d1636f796abacf0b8f83f8b24037baec3b
    BUG: 1291208
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/12989
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Kaushal 2016-04-19 03:51:02 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.