Bug 1291255 - [RFE] Support for filesystem unmount action at [clients] section of gdeploy configuration
Summary: [RFE] Support for filesystem unmount action at [clients] section of gdeploy c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat Storage
Component: gdeploy
Version: rhgs-3.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: RHGS 3.1.3
Assignee: Nandaja Varma
QA Contact: Anush Shetty
URL:
Whiteboard:
Depends On:
Blocks: 1311386
TreeView+ depends on / blocked
 
Reported: 2015-12-14 12:42 UTC by Sachidananda Urs
Modified: 2016-07-04 01:12 UTC (History)
5 users (show)

Fixed In Version: gdeploy-2.0-5
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-23 05:29:11 UTC
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1250 0 normal SHIPPED_LIVE gdeploy update for Red Hat Gluster Storage 3.1 update 3 2016-06-23 09:11:59 UTC

Description Sachidananda Urs 2015-12-14 12:42:12 UTC
Description of problem:

When filesystem is given unmount fails silently. But complains about unable to delete the the directory.


How reproducible:

Always

Steps to Reproduce:

[hosts]
10.70.47.146
10.70.47.135
10.70.47.133
10.70.47.137

[volume]
action=delete
volname=10.70.47.135:esearch
force=yes

[clients]
action=unmount
hosts=10.70.46.30
fstype=glusterfs
client_mount_points=/mnt/esearch

When the above conf is run, unmount fails.

Comment 3 Anush Shetty 2016-04-11 11:39:23 UTC
Umount works but with an error.

# gdeploy -c /opt/vol_cleanup

PLAY [master] ***************************************************************** 

TASK: [Stops a volume] ******************************************************** 
ok: [10.70.37.147]

TASK: [Deletes a volume] ****************************************************** 
ok: [10.70.37.147]

PLAY RECAP ******************************************************************** 
10.70.37.147               : ok=2    changed=0    unreachable=0    failed=0   

ERROR: /tmp/tmpgMbh6i/host_vars/10.70.37.147: Expecting property name enclosed in double quotes: line 1 column 2 (char 1)

Comment 4 Anush Shetty 2016-04-11 11:39:49 UTC
Tested with gdeploy-2.0-4.el7rhgs.noarch

Comment 5 Sachidananda Urs 2016-04-12 11:10:37 UTC
This is fixed in the latest build: gdeploy-2.0-5

Comment 6 Anush Shetty 2016-04-12 11:17:40 UTC
Verified with gdeploy-2.0-5.el7rhgs.noarch

Comment 8 errata-xmlrpc 2016-06-23 05:29:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1250


Note You need to log in before you can comment on or make changes to this bug.