Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: When filesystem is given unmount fails silently. But complains about unable to delete the the directory. How reproducible: Always Steps to Reproduce: [hosts] 10.70.47.146 10.70.47.135 10.70.47.133 10.70.47.137 [volume] action=delete volname=10.70.47.135:esearch force=yes [clients] action=unmount hosts=10.70.46.30 fstype=glusterfs client_mount_points=/mnt/esearch When the above conf is run, unmount fails.
Umount works but with an error. # gdeploy -c /opt/vol_cleanup PLAY [master] ***************************************************************** TASK: [Stops a volume] ******************************************************** ok: [10.70.37.147] TASK: [Deletes a volume] ****************************************************** ok: [10.70.37.147] PLAY RECAP ******************************************************************** 10.70.37.147 : ok=2 changed=0 unreachable=0 failed=0 ERROR: /tmp/tmpgMbh6i/host_vars/10.70.37.147: Expecting property name enclosed in double quotes: line 1 column 2 (char 1)
Tested with gdeploy-2.0-4.el7rhgs.noarch
This is fixed in the latest build: gdeploy-2.0-5
Verified with gdeploy-2.0-5.el7rhgs.noarch
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHEA-2016:1250