Bug 1291255 - [RFE] Support for filesystem unmount action at [clients] section of gdeploy configuration
[RFE] Support for filesystem unmount action at [clients] section of gdeploy c...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy (Show other bugs)
3.1
x86_64 Linux
unspecified Severity medium
: ---
: RHGS 3.1.3
Assigned To: Nandaja Varma
Anush Shetty
: FutureFeature, ZStream
Depends On:
Blocks: 1311386
  Show dependency treegraph
 
Reported: 2015-12-14 07:42 EST by Sachidananda Urs
Modified: 2016-07-03 21:12 EDT (History)
5 users (show)

See Also:
Fixed In Version: gdeploy-2.0-5
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 01:29:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2015-12-14 07:42:12 EST
Description of problem:

When filesystem is given unmount fails silently. But complains about unable to delete the the directory.


How reproducible:

Always

Steps to Reproduce:

[hosts]
10.70.47.146
10.70.47.135
10.70.47.133
10.70.47.137

[volume]
action=delete
volname=10.70.47.135:esearch
force=yes

[clients]
action=unmount
hosts=10.70.46.30
fstype=glusterfs
client_mount_points=/mnt/esearch

When the above conf is run, unmount fails.
Comment 3 Anush Shetty 2016-04-11 07:39:23 EDT
Umount works but with an error.

# gdeploy -c /opt/vol_cleanup

PLAY [master] ***************************************************************** 

TASK: [Stops a volume] ******************************************************** 
ok: [10.70.37.147]

TASK: [Deletes a volume] ****************************************************** 
ok: [10.70.37.147]

PLAY RECAP ******************************************************************** 
10.70.37.147               : ok=2    changed=0    unreachable=0    failed=0   

ERROR: /tmp/tmpgMbh6i/host_vars/10.70.37.147: Expecting property name enclosed in double quotes: line 1 column 2 (char 1)
Comment 4 Anush Shetty 2016-04-11 07:39:49 EDT
Tested with gdeploy-2.0-4.el7rhgs.noarch
Comment 5 Sachidananda Urs 2016-04-12 07:10:37 EDT
This is fixed in the latest build: gdeploy-2.0-5
Comment 6 Anush Shetty 2016-04-12 07:17:40 EDT
Verified with gdeploy-2.0-5.el7rhgs.noarch
Comment 8 errata-xmlrpc 2016-06-23 01:29:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1250

Note You need to log in before you can comment on or make changes to this bug.