Bug 1291259 - Upcall/Cache-Invalidation: Use parent stbuf while updating parent entry
Upcall/Cache-Invalidation: Use parent stbuf while updating parent entry
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: upcall (Show other bugs)
mainline
All All
unspecified Severity medium
: ---
: ---
Assigned To: Soumya Koduri
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 07:52 EST by Soumya Koduri
Modified: 2016-06-16 09:50 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:50:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Soumya Koduri 2015-12-14 07:52:00 EST
Description of problem:
While invalidating parent entries, use parent entry's stat structure in 
upcall_cache_invalidate () routine.
Comment 1 Vijay Bellur 2015-12-14 08:06:11 EST
REVIEW: http://review.gluster.org/12962 (Upcall/cache-invalidation: Use parent stbuf while updating parent entry) posted (#2) for review on master by soumya k (skoduri@redhat.com)
Comment 2 Vijay Bellur 2016-02-09 01:55:57 EST
REVIEW: http://review.gluster.org/12962 (Upcall/cache-invalidation: Use parent stbuf while updating parent entry) posted (#3) for review on master by soumya k (skoduri@redhat.com)
Comment 3 Vijay Bellur 2016-02-16 03:02:39 EST
REVIEW: http://review.gluster.org/12962 (Upcall/cache-invalidation: Use parent stbuf while updating parent entry) posted (#4) for review on master by soumya k (skoduri@redhat.com)
Comment 4 Vijay Bellur 2016-02-16 03:55:59 EST
COMMIT: http://review.gluster.org/12962 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit f4282bd927e2e0d826d62cf1192102382c5697b2
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Mon Dec 14 17:52:37 2015 +0530

    Upcall/cache-invalidation: Use parent stbuf while updating parent entry
    
    For *create*  fops (CREATE, MKDIR, MKNOD), we invalidate the parent
    entry. Hence send parent attributes in the stat field.
    
    Also "UP_PARENT_DENTRY_FLAGS" has to be set only for the fops which shall
    result in two invalidations requests - one for the inode on which fop is
    being performed and another on parent entry.
    
    In case of CREATE/MKDIR/MKNOD fops, there shall be only one invalidation
    request sent, that too on parent inode. We send invalidation directly on
    parent inode's gfid. So there is no necessity to set these flags which
    when set shall endup invalidating the parent's parent entry.
    
    Change-Id: I7514ee08382081e3e060818ede497dbca26987dc
    BUG: 1291259
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/12962
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 5 Niels de Vos 2016-06-16 09:50:45 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.