Bug 1291263 - packaging error: pkgconfig(udev) is provided by systemd, not by systemd-devel
packaging error: pkgconfig(udev) is provided by systemd, not by systemd-devel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 08:01 EST by Fabio Valentini
Modified: 2015-12-14 08:30 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-14 08:30:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabio Valentini 2015-12-14 08:01:54 EST
Description of problem:
When using pkgconfig(udev) to install development files for udev (e.g. by using BuildRequires: pkgconfig(udev) in a .spec file), the main systemd package is installed instead of systemd-devel. This seems to be an error in Provides: generation by rpm, because it is not explicitly specified in systemd.spec.

Version-Release number of selected component (if applicable):
systemd-222-8.fc23.x86_64.rpm

How reproducible:
$ sudo dnf download 'pkgconfig(udev)'

Actual results:
systemd-222-8.fc23.x86_64.rpm is downloaded

Expected results:
systemd-devel-222-8.fc23.x86_64.rpm is downloaded
Comment 1 Zbigniew Jędrzejewski-Szmek 2015-12-14 08:30:40 EST
The pkgconfig file is contained in systemd. udev.pc only contains the definition of udevdir.

You probably want libudev.pc, which is in systemd-devel. pkgconfig(libudev) is provided by systemd-devel.

Note You need to log in before you can comment on or make changes to this bug.