Bug 1291271 - Deleting users who created activation keys deletes all associated keys
Summary: Deleting users who created activation keys deletes all associated keys
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management   
(Show other bugs)
Version: 6.1.4
Hardware: All
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Tom McKay
QA Contact: Brad Buckingham
URL: http://projects.theforeman.org/issues...
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-14 13:30 UTC by Craig Donnelly
Modified: 2019-04-01 20:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 09:21:34 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Craig Donnelly 2015-12-14 13:30:30 UTC
Description of problem:
If you delete any user who has previously created an activation key that still currently exists, the key(s) will be deleted as well.

Version-Release number of selected component (if applicable): 6.1.4

How reproducible: 100%


Steps to Reproduce:
1. Create a test user of any name (I set role as admin)
2. Login to this user and create an activation key.
3. Logout of the test user, back in as another admin, and delete the user.
4. Check the activation key list.

Actual results:
Newly created activation key will now be gone.

Expected results:
Activation key should still exist.

Additional info:
This association appears to be inside of the foreman database, inside the katello_activation_key table. The 'user_id' column has the number of the user who created the activation key. If you set this id to any other user prior to deleting the one who currently owns the key, the key will continue to exist after user deletion.

Comment 1 Tom McKay 2015-12-14 13:39:46 UTC
Created redmine issue http://projects.theforeman.org/issues/12804 from this bug

Comment 3 Bryan Kearney 2015-12-14 15:01:11 UTC
Upstream bug component is Content Management

Comment 4 Bryan Kearney 2015-12-21 23:01:18 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/12804 has been closed
-------------
Thomas McKay
Applied in changeset commit:katello|01e8b42104c8a5ff532273c52730b680fa34a4a6.

Comment 6 Brad Buckingham 2016-03-24 19:28:02 UTC
Executed the scenario as described in the initial description.  After deleting the user, observed that the activation key continues to exist as desired.

Comment 9 errata-xmlrpc 2016-07-27 09:21:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.