Bug 1291351 - [7.0.z][RFE][nova]: libvirt: virtio-net multiqueue
[7.0.z][RFE][nova]: libvirt: virtio-net multiqueue
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity medium
: z5
: 7.0 (Kilo)
Assigned To: Eoghan Glynn
nlevinki
https://blueprints.launchpad.net/nova...
upstream_milestone_liberty-3 upstream...
: FutureFeature, ZStream
: 1311155 (view as bug list)
Depends On: 1153440 1291352
Blocks: 1217232 1265219 1252514 1258485 1284416
  Show dependency treegraph
 
Reported: 2015-12-14 11:34 EST by Stephen Gordon
Modified: 2016-09-16 13:28 EDT (History)
22 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1153440
Environment:
Last Closed: 2016-09-16 13:28:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1533903 None None None Never

  None (edit)
Description Stephen Gordon 2015-12-14 11:34:19 EST
+++ This bug was initially created as a clone of Bug #1153440 +++

Cloned from launchpad blueprint https://blueprints.launchpad.net/nova/+spec/libvirt-virtio-net-multiqueue.

Description:

Add supoort to enable the virtio-net multiqueue feature for guest
    instances.
    
    With virtio-net multiqueue enabled network performance can be scaled
    accross number of vCPUs, by transfering the packets through multiple virtqueue
    pairs at a time.
    
    Libvirt driver will set the number of queues equal to the number of guest VCPUs
    
    To control this feature, the following should be set in the flavour extra specs:
    
    hw:vif_multiqueue_enabled=true|disabled
    
    This setting can be overriden by the image metadata property if the feature
    is enabled in the extra specs:
    
    hw_vif_mutliqueue_enabled=true|false


Specification URL (additional information):

None

--- Additional comment from Vladik Romanovsky on 2015-09-08 12:41:53 EDT ---

The steps to enable the functionality differs from the original proposal.

Currently, the feature can only be enable or disabled for all vNICs of an instance.

A new parameter has been added to the image properties, for the users
to control the virtio-net multiqueue feature, to be able to enable or disable it.

    hw_vif_multiqueue_enabled=true|false  (default false)

The number of queues will match the number of vCPUs, defined for the instance.	

NOTE: Virtio-net multiqueue should be enabled in the guest OS manually, using	ethtool. For example:

    ethtool -L <NIC> combined #num_of_queues
Comment 4 Stephen Gordon 2016-09-05 15:56:25 EDT
*** Bug 1311155 has been marked as a duplicate of this bug. ***
Comment 5 Bertrand 2016-09-16 13:28:14 EDT
Hello,
This was discussed with Nokia on 09/16/2016. 
NOKIA agreed on closing this as "CLOSED" "WONTFIX".
Nokia has implemented their own solution.

The following was also shared with them:
[1]  https://rhn.redhat.com/errata/RHBA-2016-0636.html
[2] https://bugzilla.redhat.com/show_bug.cgi?id=1153440

Sincerely,

Bertrand

Note You need to log in before you can comment on or make changes to this bug.