Bug 1291354 - avahi doesn't build from source with updated gtk3 in RHEL 7.2
avahi doesn't build from source with updated gtk3 in RHEL 7.2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: avahi (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michal Sekletar
Petr Sklenar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 11:38 EST by Nicolas Chauvet (kwizart)
Modified: 2016-11-04 04:27 EDT (History)
4 users (show)

See Also:
Fixed In Version: avahi-0.6.31-17.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 04:27:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Chauvet (kwizart) 2015-12-14 11:38:39 EST
Description of problem:
The avahi package in RHEL 7.2 doesn't build from source with the updated gtk3 package from the same channel. It needs a backport from upstream avahi.

Version-Release number of selected component (if applicable):
avahi-0.6.31-15.el7


How reproducible:
always using rhel 7.2

Steps to Reproduce:
1. build avahi from src.rpm using rhel 7.2 build dependencies.
2.
3.

Actual results:
------
build.log
------
avahi-ui.c:1035:57: note: each undeclared identifier is reported only once for each function it appears in
In file included from /usr/include/glib-2.0/gobject/gobject.h:24:0,
                 from /usr/include/glib-2.0/gobject/gbinding.h:29,
                 from /usr/include/glib-2.0/glib-object.h:23,
                 from /usr/include/glib-2.0/gio/gioenums.h:28,
                 from /usr/include/glib-2.0/gio/giotypes.h:28,
                 from /usr/include/glib-2.0/gio/gio.h:26,
                 from /usr/include/gtk-3.0/gdk/gdkapplaunchcontext.h:28,
                 from /usr/include/gtk-3.0/gdk/gdk.h:32,
                 from /usr/include/gtk-3.0/gtk/gtk.h:30,
                 from avahi-ui.c:30:
avahi-ui.c:1036:90: error: 'GTK_STOCK_OK' undeclared (first use in this function)
     p->domain_ok_button = GTK_WIDGET(gtk_dialog_add_button(GTK_DIALOG(p->domain_dialog), GTK_STOCK_OK, GTK_RESPONSE_ACCEPT));
                                                                                          ^
/usr/include/glib-2.0/gobject/gtype.h:1933:57: note: in definition of macro '_G_TYPE_CIC'
     ((ct*) g_type_check_instance_cast ((GTypeInstance*) ip, gt))
                                                         ^
/usr/include/gtk-3.0/gtk/gtkwidget.h:58:32: note: in expansion of macro 'G_TYPE_CHECK_INSTANCE_CAST'
 #define GTK_WIDGET(widget)    (G_TYPE_CHECK_INSTANCE_CAST ((widget), GTK_TYPE_WIDGET, GtkWidget))
                                ^
avahi-ui.c:1036:27: note: in expansion of macro 'GTK_WIDGET'
     p->domain_ok_button = GTK_WIDGET(gtk_dialog_add_button(GTK_DIALOG(p->domain_dialog), GTK_STOCK_OK, GTK_RESPONSE_ACCEPT));
                           ^
avahi-ui.c: In function 'aui_service_dialog_init':
avahi-ui.c:1116:10: warning: assignment makes pointer from integer without a cast [enabled by default]
     vbox = gtk_vbox_new(FALSE, 8);
          ^
avahi-ui.c:1126:11: warning: assignment makes pointer from integer without a cast [enabled by default]
     vbox2 = gtk_vbox_new(FALSE, 8);
           ^
avahi-ui.c:1167:81: error: 'GTK_STOCK_NETWORK' undeclared (first use in this function)
     gtk_button_set_image(GTK_BUTTON(p->domain_button), gtk_image_new_from_stock(GTK_STOCK_NETWORK, GTK_ICON_SIZE_BUTTON));
------

Expected results:
Package should build from src.rpm


Additional info:
I needed to backport commit-ID: 6e109a641be45bc75b6d73f6a318bfdf294c2fbf from https://github.com/lathiat/avahi.git

Downstream distro has built avahi with the older gtk3:
http://buildlogs.centos.org/c7.1511.00/avahi/20151120103952/0.6.31-15.el7.x86_64/root.log
DEBUG util.py:282:   --> gtk3-devel-3.8.8-10.el7.x86_64
Comment 8 errata-xmlrpc 2016-11-04 04:27:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2549.html

Note You need to log in before you can comment on or make changes to this bug.