Bug 1291373 - [RFE] Allow ability to specify provider host credentials from REST API
[RFE] Allow ability to specify provider host credentials from REST API
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: John Hardy
Dave Johnson
rest:host
: FutureFeature
Depends On:
Blocks: RHCS-CFME
  Show dependency treegraph
 
Reported: 2015-12-14 12:41 EST by John Matthews
Modified: 2017-08-28 11:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-28 11:04:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2015-12-14 12:41:34 EST
Description of problem:

RHCI/RHCS is requesting the ability to set SSH credentials for infrastructure provider hosts from the REST API.

Our current approach relies on scp'ing a script to the CFME VM and executing some ruby code locally:
  https://github.com/fusor/fusor_ovirt/blob/master/bin/add_host_credentials.rb

We would like to refactor this into a call using the REST API.
Comment 3 Chris Pelland 2017-08-28 11:04:05 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.