Bug 1291382 - iPXE can't be configured with UEFI
iPXE can't be configured with UEFI
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity medium
: ga
: 9.0 (Mitaka)
Assigned To: Lucas Alvares Gomes
Raviv Bar-Tal
: Triaged
: 1242591 1284628 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 13:14 EST by Lucas Alvares Gomes
Modified: 2016-08-14 23:53 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-ironic-5.1.2-3.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the iPXE driver had a conditional that prevented nodes from being configured with UEFI boot mode. Consequently, iPXE driver users could not configure their nodes with UEFI and were forced to use the BIOS instead. With this update, the conditional was removed, and users of the iPXE driver can now deploy their nodes in UEFI mode.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-11 08:13:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1525989 None None None Never

  None (edit)
Description Lucas Alvares Gomes 2015-12-14 13:14:56 EST
Description of problem:
Ironic has a conditional preventing configuring a node with UEFI when iPXE is enabled [0], that's not needed since iPXE already supports UEFI [1].

The only difference to use UEFI with iPXE is to use the ipxe.efi ROM instead of the undionly.kpxe.

[0] https://github.com/openstack/ironic/blob/1d6f6586abe4d6df5c477cfaef16783163a69f93/ironic/drivers/modules/pxe.py#L407-L414

Version-Release number of selected component (if applicable):
8.0

How reproducible:
100%

Steps to Reproduce:
1.Update the nova flavor with boot_mode=uefi

$ nova flavor-key baremetal set capabilities:boot_mode="uefi"

2.Add the boot_mode:uefi capability in Ironic

$ ironic node-update node-0 add properties/capabilities="boot_mode:uefi"

3. Validate/Try to deploy a node

Actual results:
The deployment of the node fails saying "iPXE is enabled, but cannot be used with node <node uuid> configured to use UEFI boot"

Expected results:
Deployment should start


Additional info:
Comment 4 Lucas Alvares Gomes 2016-06-16 05:58:51 EDT
*** Bug 1284628 has been marked as a duplicate of this bug. ***
Comment 5 Lucas Alvares Gomes 2016-06-16 05:59:52 EDT
*** Bug 1242591 has been marked as a duplicate of this bug. ***
Comment 7 Miles Gould 2016-08-01 07:59:10 EDT
Step 2 should be

ironic node-update node-0 add properties/capabilities="boot_mode:uefi,boot_option:local"
Comment 9 errata-xmlrpc 2016-08-11 08:13:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1597.html

Note You need to log in before you can comment on or make changes to this bug.