Bug 1291387 - Undercloud update from 7.0 to 7.2 exits with ironic services crashed
Undercloud update from 7.0 to 7.2 exits with ironic services crashed
Status: CLOSED DUPLICATE of bug 1287309
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
x86_64 Linux
unspecified Severity medium
: ---
: 7.0 (Kilo)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 13:23 EST by Dan Yasny
Modified: 2016-04-18 02:52 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 10:25:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Yasny 2015-12-14 13:23:48 EST
Description of problem:
When running the up-update command on the UC, installed with 7.0 GA to 7.2, there are haproxy console messages duting the yum update regarding ironic being unreachable. 

Checking the openstack services after the UC is updated:
MainPID=0 Id=openstack-ironic-api.service ActiveState=failed
MainPID=0 Id=openstack-ironic-discoverd.service ActiveState=failed


Version-Release number of selected component (if applicable):
7.0 GA puddle -> 7.2 latest puddle

post update RPM versions: 
openstack-ironic-api-2015.1.2-2.el7ost.noarch
openstack-ironic-discoverd-1.1.0-8.el7ost.noarch
openstack-ironic-conductor-2015.1.2-2.el7ost.noarch
python-ironicclient-0.5.1-12.el7ost.noarch
openstack-ironic-common-2015.1.2-2.el7ost.noarch
python-ironic-discoverd-1.1.0-8.el7ost.noarch


How reproducible:
always on virt, not tested on BM yet

Steps to Reproduce:
1. install virt setup wit 7.0 GA, HA controllers etc:
Deployment command: openstack overcloud deploy --templates --control-scale 3 --compute-scale 1 --ceph-storage-scale 1   --ntp-server 10.5.26.10 --timeout 90 -e network-environment.yaml
2. start update to 7.2:
sudo rhos-release -x 
sudo rhos-release 7-director -r 7.2
yum clean all
sudo yum update

3. check the ironic service status before and after the update

Actual results:
ironic services down as noted above

Expected results:
all services remain available

Additional info:

A setup with repro is available for poking
Comment 2 Dmitry Tantsur 2016-01-13 05:39:08 EST
Hi! If it's still valid, could you please provide logs for all failed services?
Comment 3 Marius Cornea 2016-01-13 06:54:10 EST
I think this is a dup of BZ#1287309
Comment 4 Dan Yasny 2016-01-13 16:45:20 EST
(In reply to Marius Cornea from comment #3)
> I think this is a dup of BZ#1287309

I had all ironic services down after install, not just the API, but the symptoms are the same indeed.

Actually, when trying an upgrade later on, I had additional services go down. We now have the upgrade KB telling people to reboot the UC machine after the yum update, which fixes all the services in one go, and we haven't opened any additional BZs because of that.
Comment 5 Mike Burns 2016-01-27 10:25:45 EST

*** This bug has been marked as a duplicate of bug 1287309 ***

Note You need to log in before you can comment on or make changes to this bug.