Bug 1291389 - include nodemon in nodejs SCL
include nodemon in nodejs SCL
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: distribution (Show other bugs)
nodejs010
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.1
Assigned To: Tomas Hrcka
Miroslav Hradílek
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 13:25 EST by Ben Parees
Modified: 2016-02-22 09:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 09:22:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Parees 2015-12-14 13:25:38 EST
Description of problem:

Nodemon(http://nodemon.io/) is a popular library for enabling automatic restart of nodejs apps to pick up file changes.  

We'd like to have this library available as part of the nodejs package.

This is particularly important to openshift as it would enable us to have a "hot deploy" mode available to the NodeJS image so users can push code changes to running images and see the changes reflected immediately rather than having to build a new image w/ new code, and then stop the existing container and start a new one.

We need it in an official package so we can build official images that include this library, downloading it from the internet is not acceptable for building images we will distribute.

See more details here:
https://github.com/openshift/origin/pull/5976#issuecomment-164425350
Comment 2 Joe Orton 2016-01-20 10:12:26 EST
Ben, Tomas/Zuzana, will it be sufficient to add this to the new rh-node4 collection in RHSCL 2.2, or are you requesting that this is added to nodejs010 specifically?
Comment 3 Ben Parees 2016-01-20 10:13:42 EST
Request is for nodejs010.  Eliska should have the details.
Comment 7 errata-xmlrpc 2016-02-22 09:22:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0285.html

Note You need to log in before you can comment on or make changes to this bug.