Bug 1291445 - CFME 5.3.3 Zone Level Log collection incorrectly references and uses the appliance level log depot instead of zone level specified depot
CFME 5.3.3 Zone Level Log collection incorrectly references and uses the appl...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.3.0
x86_64 Linux
high Severity medium
: GA
: 5.5.2
Assigned To: Libor Pichler
Kyrylo Zvyagintsev
: ZStream
Depends On: 1197869
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 16:36 EST by John Prause
Modified: 2016-02-10 10:24 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1197869
Environment:
Last Closed: 2016-02-10 10:24:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Joe Rafaniello 2016-01-19 09:28:14 EST
Implemented upstream in https://github.com/ManageIQ/manageiq/pull/5864, fixing: https://github.com/ManageIQ/manageiq/issues/1962
Comment 5 Joe Rafaniello 2016-01-19 15:38:22 EST
Libor, can you see how hard it is to backport this to 5.5.z?  From your changes, I don't see a lot of conflicts happening but you never know until you try.

Thanks!
Comment 7 CFME Bot 2016-01-20 14:31:52 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=3b2299330c6aea11cb1d9142654f8ebc2c29ee84

commit 3b2299330c6aea11cb1d9142654f8ebc2c29ee84
Merge: 73e18b0 f454638
Author:     Joe Rafaniello <jrafanie@redhat.com>
AuthorDate: Wed Jan 20 14:25:31 2016 -0500
Commit:     Joe Rafaniello <jrafanie@redhat.com>
CommitDate: Wed Jan 20 14:25:31 2016 -0500

    Merge branch 'bz_1291445' into '5.5.z'
    
    Change logic of choosing depot for collection log
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1291445
    https://github.com/ManageIQ/manageiq/pull/5864
    
    It was clean cherry-pick expect to some specs(diagnostic_specs.rb, log_management_spec.rb), but there were just few conflicts about
    converting matchers:
    XXXX.should
    to
    XXX.to
    
    
    See merge request !736

 app/controllers/ops_controller/diagnostics.rb      |   3 +-
 app/helpers/application_helper/toolbar_builder.rb  |  12 +-
 app/models/miq_server/log_management.rb            |  17 ++-
 app/models/zone.rb                                 |   5 +-
 app/views/ops/_logs_selected.html.haml             |   2 +-
 .../controllers/ops_controller/diagnostics_spec.rb |  10 +-
 .../application_helper/toolbar_builder_spec.rb     | 111 +++++++++++++-
 spec/models/miq_server/log_management_spec.rb      | 163 +++++++++++++++++++--
 8 files changed, 290 insertions(+), 33 deletions(-)
Comment 10 errata-xmlrpc 2016-02-10 10:24:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.