Bug 1291461 - qt linux-g++-aarch64 mkspec is nonstandard
qt linux-g++-aarch64 mkspec is nonstandard
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qt (Show other bugs)
7.2
aarch64 Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Grulich
Desktop QE
:
Depends On:
Blocks: 1277314 epel7aarch64 1297830 1313485
  Show dependency treegraph
 
Reported: 2015-12-14 16:57 EST by Yaakov Selkowitz
Modified: 2016-11-03 21:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 21:28:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaakov Selkowitz 2015-12-14 16:57:59 EST
The arch-specific linux-g++-aarch64 mkspec, based on an earlier aarch64 patch for Fedora qt, exists primarily to add -fpermissive for JSC.  However, as a nonstandard mkspec, qmake-based projects would not be expected to check for it, resulting in build issues when only the known linux-g++ mkspecs are used in a conditional.  This is causing epel7 x2goclient to FTBFS on RHELSA 7.2.

Please rebase the aarch64 patch to a more recent Fedora version, which uses a standard linux-g++ mkspec.
Comment 1 Jan Grulich 2016-01-19 03:43:33 EST
Can be done, granting dev_ack+.
Comment 2 Jan Grulich 2016-03-24 05:41:54 EDT
Fixed in qt-4.8.5-12.el7.
Comment 5 errata-xmlrpc 2016-11-03 21:28:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2236.html

Note You need to log in before you can comment on or make changes to this bug.