Bug 1291514 - starting nfs-server.target changes permissions on /var/lib/nfs/rpc_pipefs causing 'rpm --verify' issues
starting nfs-server.target changes permissions on /var/lib/nfs/rpc_pipefs cau...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils (Show other bugs)
7.2
All Linux
high Severity medium
: rc
: ---
Assigned To: Steve Dickson
Yongcheng Yang
: TestCaseProvided
: 1275541 1325621 1360838 (view as bug list)
Depends On:
Blocks: 1203710 1313485 1295577 1364088
  Show dependency treegraph
 
Reported: 2015-12-14 21:51 EST by Karl Hastings
Modified: 2016-11-04 01:02 EDT (History)
10 users (show)

See Also:
Fixed In Version: nfs-utils-1.3.0-0.24.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:02:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2193991 None None None 2016-03-09 04:30 EST

  None (edit)
Description Karl Hastings 2015-12-14 21:51:33 EST
Description of problem:
nfs-utils-1.3.0-0.21.el7.x86_64 creates the directory /var/lib/nfs/rpc_pipefs as mode 755 (rwxr-xr-x), once you `systemctl start nfs-server.target` the pseudo filesystem gets mounted and the permissions are changed to 555 (r-xr-xr-x).

This causes rpm -V to throw errors, which causes it's own issues in environments where rpm -V errors have strict requirements...

[root@test ~]# rpm -V nfs-utils
.M.......    /var/lib/nfs/rpc_pipefs


Version-Release number of selected component (if applicable):
nfs-utils-1.3.0-0.21.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.  yum install nfs-utils
2.  ls -lad /var/lib/nfs/rpc_pipefs
3.  systemctl start nfs-server.target
4.  ls -lad /var/lib/nfs/rpc_pipefs
5.  rpm -V nfs-utils
Comment 6 Steve Dickson 2016-04-28 10:33:17 EDT
*** Bug 1275541 has been marked as a duplicate of this bug. ***
Comment 7 Steve Dickson 2016-04-28 10:52:59 EDT
*** Bug 1325621 has been marked as a duplicate of this bug. ***
Comment 9 Yongcheng Yang 2016-06-02 04:42:14 EDT
Patch applies to nfs-utils-1.3.0-0.24.el7

[root@hp-dl380pg8-10 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.21.el7.x86_64
[root@hp-dl380pg8-10 ~]# rpm -qlv nfs-utils-1.3.0-0.21.el7.x86_64 | grep /var/lib/nfs/rpc_pipefs
drwxr-xr-x    2 root    root                        0 Sep 29  2015 /var/lib/nfs/rpc_pipefs
[root@hp-dl380pg8-10 ~]# 
[root@hp-dl380pg8-10 ~]# rpm -qlvp nfs-utils-1.3.0-0.24.el7.x86_64.rpm | grep /var/lib/nfs/rpc_pipefs
dr-xr-xr-x    2 root    root                        0 Apr 28 14:11 /var/lib/nfs/rpc_pipefs
[root@hp-dl380pg8-10 ~]#
Comment 12 Yongcheng Yang 2016-06-14 05:30:00 EDT
Move to VERIFIED as comment 10, and will continue to run the automatic case
Comment 13 Yongcheng Yang 2016-07-27 20:49:37 EDT
*** Bug 1360838 has been marked as a duplicate of this bug. ***
Comment 15 errata-xmlrpc 2016-11-04 01:02:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2383.html

Note You need to log in before you can comment on or make changes to this bug.