Bug 1291536 - It's better to remove parallel devices from virt-install and virt-manager and the relevant docs of them
It's better to remove parallel devices from virt-install and virt-manager and...
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager (Show other bugs)
7.2
x86_64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Pavel Hrdina
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 00:39 EST by xiaodwan
Modified: 2017-03-02 14:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-02 14:50:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xiaodwan 2015-12-15 00:39:12 EST
Description of problem:
It's better to remove parallel devices from virt-install and virt-manager and the relevant docs of them.

Version-Release number of selected component (if applicable):
virt-manager-1.2.1-8.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Run "virt-install --name demo --memory 1024 --disk /var/lib/libvirt/images/demo.img,size=1 -l http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL-7.2-20151030.0/compose/Server/x86_64/os/ --noreboot --parallel pty --debug".


Actual results:
[Wed, 09 Dec 2015 17:08:38 virt-install 7930] ERROR (cli:296) internal error: process exited while connecting to monitor: 2015-12-09T09:08:38.683764Z qemu-kvm: -device isa-parallel,chardev=charparallel0,id=parallel0: 'isa-parallel' is not a valid device model name.

Expected results:
Since parallel devices are not supported in downstream, it's better to remove --parallel from virt-install and parallel hardware from virt-manager. 
And remove --parallel options from virt-install --help and man page of virt-install.

Additional info:
Comment 1 Pavel Hrdina 2016-05-26 03:09:20 EDT
Moving to RHEL-7.4, this is a minor issue.
Comment 3 Cole Robinson 2017-03-02 14:50:11 EST
Honestly, I don't think this is even worth tracking. The amount of people that will even attempt to use parallel dev emulation on RHEL is very very small, and we return an error so at least it's clear on that front. Pavel's suggestion of getting this info from libvirt is a good one but it's not important enough to track for RHEL.

Note You need to log in before you can comment on or make changes to this bug.