Bug 1291546 - bitrot: bitrot scrub status command should display the correct value of total number of scrubbed, unsigned file
bitrot: bitrot scrub status command should display the correct value of total...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: bitrot (Show other bugs)
3.7.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gaurav Kumar Garg
bugs@gluster.org
:
Depends On: 1285989 1329211
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 01:13 EST by Gaurav Kumar Garg
Modified: 2016-06-05 19:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1285989
Environment:
Last Closed: 2016-04-19 03:51:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaurav Kumar Garg 2015-12-15 01:13:56 EST
+++ This bug was initially created as a clone of Bug #1285989 +++

Description of problem:

if user execute bitrot scrub status command then it should display correct value of total number of scrubbed file, total number of unsigned file, and last scrub time.

--- Additional comment from Vijay Bellur on 2015-11-27 02:22:00 EST ---

REVIEW: http://review.gluster.org/12776 (bitrot: getting correct value of scrub stat's) posted (#1) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-27 10:57:21 EST ---

REVIEW: http://review.gluster.org/12776 (bitrot: getting correct value of scrub stat's) posted (#2) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-03 22:45:33 EST ---

REVIEW: http://review.gluster.org/12776 (bitrot: getting correct value of scrub stat's) posted (#4) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-04 04:43:14 EST ---

REVIEW: http://review.gluster.org/12776 (bitrot: getting correct value of scrub stat's) posted (#5) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-09 04:15:15 EST ---

REVIEW: http://review.gluster.org/12776 (bitrot: getting correct value of scrub stat's) posted (#6) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-09 04:46:28 EST ---

REVIEW: http://review.gluster.org/12776 (bitrot: getting correct value of scrub stat's) posted (#7) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-09 06:38:21 EST ---

REVIEW: http://review.gluster.org/12776 (bitrot: getting correct value of scrub stat's) posted (#8) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-10 02:18:31 EST ---

REVIEW: http://review.gluster.org/12776 (bitrot: getting correct value of scrub stat's) posted (#9) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-10 03:45:07 EST ---

REVIEW: http://review.gluster.org/12776 (bitrot: getting correct value of scrub stat's) posted (#10) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-14 22:08:43 EST ---

COMMIT: http://review.gluster.org/12776 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 22827d51c232c44a8f5ac003529d907d93baf7b0
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Wed Nov 25 17:38:43 2015 +0530

    bitrot: getting correct value of scrub stat's
    
    When user execute bitrot scrub status command then gluster
    is not giving correct value of Number of Scrubbed files,
    Number of Unsigned files, Last completed scrub time,
    Duration of last scrub.
    
    With this patch scrub status will give correct value for
    all the above fields.
    
    Change-Id: Ic966f76d22db5b0c889e6386a1c2219afbda1f49
    BUG: 1285989
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/12776
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 1 Vijay Bellur 2015-12-15 01:15:57 EST
REVIEW: http://review.gluster.org/12966 (bitrot: getting correct value of scrub stat's) posted (#1) for review on release-3.7 by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 2 Vijay Bellur 2015-12-17 22:29:06 EST
COMMIT: http://review.gluster.org/12966 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit 530533fe44f08f30d1230c65db0054be7c6d3281
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Wed Nov 25 17:38:43 2015 +0530

    bitrot: getting correct value of scrub stat's
    
    This patch is backport of: http://review.gluster.org/#/c/12776/
    
    When user execute bitrot scrub status command then gluster
    is not giving correct value of Number of Scrubbed files,
    Number of Unsigned files, Last completed scrub time,
    Duration of last scrub.
    
    With this patch scrub status will give correct value for
    all the above fields.
    
      >> Change-Id: Ic966f76d22db5b0c889e6386a1c2219afbda1f49
      >> BUG: 1285989
      >> Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
      >> Signed-off-by: Kotresh HR <khiremat@redhat.com>
      >> Reviewed-on: http://review.gluster.org/12776
      >> Tested-by: NetBSD Build System <jenkins@build.gluster.org>
      >> Tested-by: Gluster Build System <jenkins@build.gluster.com>
      >> Reviewed-by: Venky Shankar <vshankar@redhat.com>
    
    Change-Id: Ic966f76d22db5b0c889e6386a1c2219afbda1f49
    BUG: 1291546
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    
    
    (cherry picked from commit 22827d51c232c44a8f5ac003529d907d93baf7b0)
    
    Change-Id: Icef24cce35c8d54ffdfa5282491338318e78780b
    Reviewed-on: http://review.gluster.org/12966
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 3 Vijay Bellur 2016-01-12 01:12:55 EST
REVIEW: http://review.gluster.org/13223 (glusterd/cli: mask out inaccurate scrub statistics) posted (#1) for review on release-3.7 by Venky Shankar (vshankar@redhat.com)
Comment 4 Vijay Bellur 2016-01-26 09:18:55 EST
REVIEW: http://review.gluster.org/13223 (glusterd/cli: mask out inaccurate scrub statistics) posted (#2) for review on release-3.7 by Venky Shankar (vshankar@redhat.com)
Comment 5 Vijay Bellur 2016-01-27 06:50:02 EST
COMMIT: http://review.gluster.org/13223 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 1643209297664462ffabc04a4fe667f2fb9be741
Author: Venky Shankar <vshankar@redhat.com>
Date:   Tue Dec 29 10:54:55 2015 +0530

    glusterd/cli: mask out inaccurate scrub statistics
    
            Backport of http://review.gluster.org/13105
    
    Some of the scrub statistics are inaccurate at the moment and would
    successfully fool users at times. It's best to not display these
    stats and stick to what is accurate.
    
    Note that the change is only in the CLI part - glusterd (and brick)
    supplies _all_ available scrub statistics, but CLI just selectively
    sticks to what needs to be displayed.
    
    Change-Id: Ia99f505a2cb10d5406cd37035d082e593f7e9a8c
    BUG: 1291546
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-on: http://review.gluster.org/13223
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 6 Kaushal 2016-04-19 03:51:02 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.