Bug 1291573 - Sphinx Exception NotImplementedError: Unknown node: inline
Summary: Sphinx Exception NotImplementedError: Unknown node: inline
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-sphinx
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Charalampos Stratakis
QA Contact: David Kutálek
Marc Muehlfeld
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks: 1288743 1332519
TreeView+ depends on / blocked
 
Reported: 2015-12-15 08:19 UTC by Nick
Modified: 2016-11-04 01:02 UTC (History)
11 users (show)

(edit)
The _python-sphinx_ module no longer fails to build documentation

Previously, the man-page writer module of the _python-sphinx_ package missed the "meta" and "inline" node visitors. As a consequence, building documentation could fail. A patch has been provided to add the missing node visitors and as a result, documentation now builds successfully.
Clone Of:
: 1332519 (view as bug list)
(edit)
Last Closed: 2016-11-04 01:02:59 UTC


Attachments (Terms of Use)
Patch (515 bytes, patch)
2015-12-15 08:19 UTC, Nick
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2222 normal SHIPPED_LIVE python-sphinx bug fix and enhancement update 2016-11-03 13:25:51 UTC

Description Nick 2015-12-15 08:19:22 UTC
Created attachment 1105924 [details]
Patch

Description of problem:

When building docs for letsencrypt it throws this error:

writing... letsencrypt.7 { intro using contributing packaging api api/account api/achallenges api/auth_handler api/client api/configuration api/constants api/continuity_auth api/crypto_util api/display api/errors api/index api/interfaces api/le_util api/log api/plugins/common api/plugins/disco api/plugins/manual api/plugins/standalone api/plugins/util api/plugins/webroot api/proof_of_possession api/renewer api/reporter api/reverter api/storage }
Exception occurred:
  File "/usr/lib/python2.7/site-packages/sphinx/writers/manpage.py", line 344, in unknown_visit
    raise NotImplementedError('Unknown node: ' + node.__class__.__name__)
NotImplementedError: Unknown node: inline


Version-Release number of selected component (if applicable):

1.1.3-9

How reproducible:


Steps to Reproduce:
1. git clone https://github.com/letsencrypt/letsencrypt.git
2. cd letsencrypt
3. python setup.py build
4. make -C docs html man

Actual results:

The error posted above

Expected results:

writing... letsencrypt.7 { intro using contributing packaging api api/account api/achallenges api/auth_handler api/client api/configuration api/constants api/continuity_auth api/crypto_util api/display api/errors api/index api/interfaces api/le_util api/log api/plugins/common api/plugins/disco api/plugins/manual api/plugins/standalone api/plugins/util api/plugins/webroot api/proof_of_possession api/renewer api/reporter api/reverter api/storage } letsencrypt.1 { } letsencrypt-renewer.1 { }
build succeeded.


The attached patch seems to fix the issue

Comment 4 Jon Schlueter 2016-03-23 18:40:42 UTC
Also seeing this issue trying to build openstack-sahara for RH OSP 9

Comment 6 Charalampos Stratakis 2016-03-24 09:51:43 UTC
Trying to reproduce it I get this error when building the docs.

Exception occurred:
  File "/builddir/build/RPMS/letsencrypt/docs/conf.py", line 133, in <module>
    import sphinx_rtd_theme
ImportError: No module named sphinx_rtd_theme

Comment 7 Nick 2016-03-30 01:13:13 UTC
You'll need python-sphinx_rtd_theme from EPEL

Comment 9 Charalampos Stratakis 2016-03-30 10:03:11 UTC
So a reproducer for a clean RHEL 7.2 system would be

1. Enable the optional repository to get python-sphinx:
 # subscription-manager repos --enable rhel-7-workstation-optional-rpms

2. Enable the epel repositories:
 # wget http://dl.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-5.noarch.rpm
 # rpm -ivh epel-release-7-5.noarch.rpm

3. Install the required packages::
# yum install git python-sphinx python-spinx_rtd_theme python-repoze-sphinx-autointerface python2-sphinxcontrib-programoutput

4. git clone https://github.com/letsencrypt/letsencrypt.git
5. cd letsencrypt
6. python setup.py build
7. make -C docs html man

By applying the patch, building of docs is successful.

Comment 16 errata-xmlrpc 2016-11-04 01:02:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2222.html


Note You need to log in before you can comment on or make changes to this bug.