Bug 1291646 - Main tabs and search bar disappear when browser window is too narrow
Main tabs and search bar disappear when browser window is too narrow
Status: CLOSED WONTFIX
Product: ovirt-engine
Classification: oVirt
Component: Frontend.Core (Show other bugs)
3.6.1
Unspecified Unspecified
low Severity low (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Alexander Wels
Petr Matyáš
ux
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 06:54 EST by Petr Matyáš
Modified: 2016-02-10 14:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 09:12:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ecohen: ovirt‑4.0.0?
pmatyas: planning_ack?
ecohen: devel_ack+
pmatyas: testing_ack?


Attachments (Terms of Use)
webadmin - screenshot (67.64 KB, image/png)
2015-12-15 06:54 EST, Petr Matyáš
no flags Details
screen-cast: main tabs and search bar disappearing point (2.18 MB, application/ogg)
2016-01-12 09:22 EST, Einav Cohen
no flags Details

  None (edit)
Description Petr Matyáš 2015-12-15 06:54:07 EST
Created attachment 1105955 [details]
webadmin - screenshot

Description of problem:
When you make your browser window too narrow, the main tabs disappear on both webadmin and userportal. In userportal Basic/Extended tabs disappear. In webadmin it's all the main tabs on top.

Version-Release number of selected component (if applicable):
3.6.1-4

How reproducible:
always

Steps to Reproduce:
1. open userportal or webadmin in browser
2. make your browser narrower and narrower till the tabs disappear
3.

Actual results:
main tabs are not visible

Expected results:
main tabs are visible correctly on any width

Additional info:
Comment 1 Yaniv Kaul 2016-01-10 03:33:48 EST
Reducing to low as a workaround exists: don't make your browser window too narrow.
Comment 2 Einav Cohen 2016-01-12 09:22 EST
Created attachment 1113956 [details]
screen-cast: main tabs and search bar disappearing point
Comment 3 Einav Cohen 2016-01-12 09:26:53 EST
see attachment 1113956 [details] - it looks like the main tabs and search bar are disappearing when the window width / resolution width is ~770px. I don't think that anyone today uses a screen width resolution of less than 1024px. 

I am guessing that the entire search-bar/main-tabs banner is being "cut" to a second "line", leaving a blank banner on the first "line". 

@Alexander - is this something that can be easily fixed, without risking the behaviour for other (higher) resolutions? if so - please fix. If not - please close on WONT_FIX. Thanks.
Comment 4 Alexander Wels 2016-01-13 09:12:45 EST
Well the actual problem is that once you get below a certain size, the header switches to mobile size mode (see the little hamburger icon at the top right in the screen shot) and menu is not designed to properly go into hamburger mode. Its been doing this since we introduced patternfly in the product (3.5?). Unless we spend quite a bit of time making this work properly, I don't think we can do much about it at this point in time, so I would recommend close won't fix at this point.

Note You need to log in before you can comment on or make changes to this bug.