Bug 1291692 - Checkbox not available to Hide the Value of parameter even after override button checked.
Summary: Checkbox not available to Hide the Value of parameter even after override but...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: orabin
QA Contact: Jitendra Yejare
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1297736 (view as bug list)
Depends On:
Blocks: 1278718
TreeView+ depends on / blocked
 
Reported: 2015-12-15 13:00 UTC by Jitendra Yejare
Modified: 2019-09-25 21:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:00:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 12828 None None None 2016-04-22 14:56:17 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Jitendra Yejare 2015-12-15 13:00:23 UTC
Description of problem:

The checkbox to hide the value of parameter is not available after checking Override button but without saving the override change to parameter.

Workaround: Override the parameter first, save the changes to parameter. Again edit the parameter, the checkbox to hide the value of parameter will be available to check/uncheck.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Edit new puppet class parameter.
2. Click on override button to override its value, but dont save/submit the changes.
3. See the availability of 'Hidden Value' Checkbox.

Actual results:
Checkbox not available to Hide the Value of parameter.

Expected results:
Checkbox should be available to Hide the Value of parameter.

Additional info:

Comment 1 Jitendra Yejare 2015-12-15 13:43:44 UTC
Created redmine issue http://projects.theforeman.org/issues/12828 from this bug

Comment 3 Bryan Kearney 2015-12-15 15:01:44 UTC
Upstream bug assigned to orabin@redhat.com

Comment 4 Bryan Kearney 2015-12-15 15:01:46 UTC
Upstream bug component is Provisioning

Comment 5 Bryan Kearney 2015-12-15 15:01:47 UTC
Upstream bug assigned to orabin@redhat.com

Comment 6 Bryan Kearney 2015-12-16 15:01:41 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/12828 has been closed
-------------
Ori Rabin
Applied in changeset commit:fd1e12218b35ae6a37ee728f272037f58216a60b.

Comment 9 orabin 2016-01-13 07:37:42 UTC
*** Bug 1297736 has been marked as a duplicate of this bug. ***

Comment 10 Jitendra Yejare 2016-01-27 12:34:57 UTC
Verified this issue in upstream.

Build : foreman-1.11.0-0.develop.201601251557git59dc77b.el6.noarch

Comment 12 Jitendra Yejare 2016-03-22 09:20:43 UTC
Verified this bug in Sat 6.2 snap 4,

The issue is no more reproducible.

I see the 'Hidden Value' checkbox is immediately enabled to check on checkinf 'override' checkbox.

So changing the state to Verified.

Comment 15 errata-xmlrpc 2016-07-27 09:00:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.