Bug 1291697 - ISO upgrade from 3.1.1 to 3.1.2 shows ctdb related error.
ISO upgrade from 3.1.1 to 3.1.2 shows ctdb related error.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
3.1
x86_64 Linux
unspecified Severity high
: ---
: RHGS 3.1.2
Assigned To: Bug Updates Notification Mailing List
Shashank Raj
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 08:10 EST by Shashank Raj
Modified: 2016-11-07 22:52 EST (History)
6 users (show)

See Also:
Fixed In Version: samba-4.2.4-11.el6rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 01:13:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shashank Raj 2015-12-15 08:10:13 EST
Description of problem:

ISO upgrade from 3.1.1 to 3.1.2 shows ctdb related error as below
restorecon:  lstat(/usr/sbin/ctdbd_wrapper) failed:  No such file or directory
warning: %posttrans(samba-0:4.2.4-8.el6rhs.x86_64) scriptlet failed, exit status 255
Non-fatal POSTTRANS scriptlet failure in rpm package samba-4.2.4-8.el6rhs.x86_64


Version-Release number of selected component (if applicable):
glusterfs-3.7.5-11

How reproducible:
Once

Steps to Reproduce:
1. Install 3.1.1 ISO  on a machine.
2. Create a repo tree out of 3.1.2 ISO of latest glusterfs-3.7.5-11 build.
3. Subscribe 3.1.1 machine to the repo generated in step 2
4. Do a yum update on the 3.1.1 machine.
5. Observe that the upgrade was successful however below error message is observed during upgrade.

restorecon:  lstat(/usr/sbin/ctdbd_wrapper) failed:  No such file or directory
warning: %posttrans(samba-0:4.2.4-8.el6rhs.x86_64) scriptlet failed, exit status 255
Non-fatal POSTTRANS scriptlet failure in rpm package samba-4.2.4-8.el6rhs.x86_64

6. Below are the samba packages shown on the machine after upgrade.

root@dhcp35-24# rpm -qa|grep samba

samba-libs-4.2.4-8.el6rhs.x86_64
samba-common-libs-4.2.4-8.el6rhs.x86_64
samba-common-tools-4.2.4-8.el6rhs.x86_64
samba-client-libs-4.2.4-8.el6rhs.x86_64
samba-4.2.4-8.el6rhs.x86_64
samba-client-4.2.4-8.el6rhs.x86_64
samba-vfs-glusterfs-4.2.4-8.el6rhs.x86_64
samba-common-4.2.4-8.el6rhs.noarch

Actual results:


Expected results:

there should be no errors during upgrade.

Additional info:
Comment 2 Jose A. Rivera 2015-12-15 08:17:21 EST
It seems the CTDB package is missing.
Comment 3 Jose A. Rivera 2015-12-15 08:57:38 EST
Oh, oops. On closer inspection, we missed a posttrans line. We'll get the fix in shortly. :)
Comment 5 surabhi 2015-12-23 00:59:30 EST
Corrected the fixed in version: It is done in Samba RPM's.
Comment 6 Shashank Raj 2015-12-24 03:42:28 EST
With the latest ISO for glusterfs-3.7.5-13 having samba-4.2.4-11 packages, the issue is no more reproducible.

Hence marking this bug as Verified.
Comment 8 errata-xmlrpc 2016-03-01 01:13:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0324.html

Note You need to log in before you can comment on or make changes to this bug.