Bug 129172 - Rebuilding of coreutils dies with "bad substitution"
Summary: Rebuilding of coreutils dies with "bad substitution"
Status: CLOSED DUPLICATE of bug 129128
Alias: None
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-04 18:27 UTC by Robert Scheck
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2004-08-04 18:27:56 UTC
Description of problem:
Rebuilding of coreutils dies here with this error message:

--- snipp ---
# rpmbuild -ba coreutils.spec
+ install -m 4755 src/su /var/tmp/coreutils-root/bin
+ for i in hostname uptime kill
/var/tmp/rpm-tmp.23363: line 76: $RPM_BUILD_ROOT/usr/share/man/man1/${i.1}: bad substitution
error: Bad exit status from /var/tmp/rpm-tmp.23363 (%install)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.23363 (%install)
#
--- snapp ---

Version-Release number of selected component (if applicable):
coreutils-5.2.1-18

How reproducible / Steps to Reproduce:
Everytime, see above.

Actual results:
--- snipp ---
--- coreutils.spec      2004-08-04 20:04:56.000000000 +0200
+++ coreutils.spec.rsc  2004-08-04 20:20:21.000000000 +0200
@@ -186,7 +186,7 @@

 # These come from util-linux and/or procps.
 for i in hostname uptime kill ; do
-       rm -f $RPM_BUILD_ROOT{%_bindir/$i,%_mandir/man1/${i}.1}
+       rm -f $RPM_BUILD_ROOT{%_bindir/$i,%_mandir/man1/$i.1}
 done

 %{?!nopam:install -m 644 %SOURCE200 $RPM_BUILD_ROOT%_sysconfdir/pam.d/su}
--- snapp ---

Expected results:
Rebuild without error... ;-)

Additional info:
Maybe it's of belong, but I'm rebuilding at bash (bash3).

Comment 1 Tim Waugh 2004-08-04 22:07:14 UTC

*** This bug has been marked as a duplicate of 129128 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:04:56 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.