Bug 1291775 - [RFE] Choose puppet class while creating a Smart Variable from any other class.
[RFE] Choose puppet class while creating a Smart Variable from any other class.
Status: CLOSED DUPLICATE of bug 1373447
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Smart Variables (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
http://projects.theforeman.org/issues...
: FutureFeature, Triaged
Depends On:
Blocks: 1278718
  Show dependency treegraph
 
Reported: 2015-12-15 10:15 EST by Jitendra Yejare
Modified: 2016-12-13 06:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-13 06:34:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12833 None None None 2016-04-22 11:49 EDT

  None (edit)
Description Jitendra Yejare 2015-12-15 10:15:37 EST
Description of problem:
I believe we should be able to choose puppet class while creating a Smart Variable. As of now we can do that after editing variable.

Version-Release number of selected component (if applicable):


How reproducible:
Always 

Scenario 1:
Steps to Reproduce:
-> From Config -> Classes -> Class -> Smart Variables, create a new Smart Variable.
Actual results:
-> The smart variable is created in the same class from where we created it.

Scenario 2:
Steps:
-> Edit the above created variable. And Change the Puppet Class it belongs to.
Actual Result:
This changes the puppet class of that smart variable.

Expected results:
we should be able to choose puppet class while 'creating' Smart Variable.

Additional info:
Comment 4 Ivan Necas 2016-04-26 08:16:22 EDT
I'm not sure being able to select a puppet class for a smart variable while being in a context of one puppet class wouldn't cause too much confusion. What about being able to create a smart variable from the list of smart variables?

IMO that would make more sense and could be prepared for non-puppet smart variables.
Comment 5 Ivan Necas 2016-04-26 08:35:38 EDT
Moving target to 6.3, as it would not make much sense until we have puppet-independent class variables
Comment 6 Jitendra Yejare 2016-06-06 04:25:36 EDT
@Ivan,

Good Suggestion ! I would vote for creating a smart var from Smart Variables list which will allow us to choose puppet class there itself.
Comment 7 Bryan Kearney 2016-07-08 16:39:51 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 9 Bryan Kearney 2016-08-10 15:12:12 EDT
Upstream bug component is Configuration Management
Comment 10 Bryan Kearney 2016-08-10 16:13:10 EDT
Upstream bug component is Provisioning
Comment 11 Bryan Kearney 2016-08-10 18:12:49 EDT
Upstream bug component is Configuration Management
Comment 12 Bryan Kearney 2016-08-12 08:50:37 EDT
Upstream bug component is Smart Variables
Comment 13 orabin 2016-12-13 06:34:14 EST
As per comment 6 this request has changed to allow creating a new smart variable from the smart variable list, which already has a bz: 1373447.

*** This bug has been marked as a duplicate of bug 1373447 ***

Note You need to log in before you can comment on or make changes to this bug.