This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1291777 - Problems upgrading Satellite 6.1.2, version 2.6.0.17 of dependency python-pulp-common missing
Problems upgrading Satellite 6.1.2, version 2.6.0.17 of dependency python-pul...
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.1.2
x86_64 Linux
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 10:16 EST by Anders Nordby
Modified: 2015-12-23 07:33 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-23 07:33:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from yum update command (51.29 KB, text/plain)
2015-12-15 10:16 EST, Anders Nordby
no flags Details

  None (edit)
Description Anders Nordby 2015-12-15 10:16:42 EST
Created attachment 1106068 [details]
Log from yum update command

Description of problem:

Running Satellite 6.1 in Red Hat 7.1 I get errors when trying to update all packages due to failed dependencies.

Version-Release number of selected component (if applicable):

2.6.0.17

How reproducible:
Run yum update

Steps to Reproduce:
1. Run yum update

Actual results:

(..)
Error: Package: pulp-server-2.6.0.17-1.el7sat.noarch (rhel-7-server-satellite-6.1-rpms)
           Requires: python-pulp-common = 2.6.0.17
           Installed: python-pulp-common-2.6.0.15-1.el7sat.noarch (@rhel-7-server-satellite-6.1-rpms)
               python-pulp-common = 2.6.0.15-1.el7sat
           Available: python-pulp-common-2.4.1-0.7.beta.el7sat.noarch (rhel-7-server-rh-common-rpms)
               python-pulp-common = 2.4.1-0.7.beta.el7sat
(..)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
No error messages :-)

Additional info:

Latest version of python-pulp-common is 2.6.0.15. I need 2.6.0.17. Where is it?

[root@no000010ssat01 ~]# yum provides python-pulp-common
Loaded plugins: priorities, product-id, subscription-manager
307 packages excluded due to repository priority protections
python-pulp-common-2.4.1-0.7.beta.el7sat.noarch : Pulp common python packages
Repo        : rhel-7-server-rh-common-rpms



python-pulp-common-2.6.0.15-1.el7sat.noarch : Pulp common python packages
Repo        : @rhel-7-server-satellite-6.1-rpms
Comment 1 Anders Nordby 2015-12-23 07:32:47 EST
Disabling the common repository solved my problem.

Note You need to log in before you can comment on or make changes to this bug.