Bug 1291814 - RFE To expose VDBs as Geospatial databases
RFE To expose VDBs as Geospatial databases
Status: CLOSED UPSTREAM
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Van Halbert
Filip Elias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 11:06 EST by Stelios Kousouris
Modified: 2015-12-21 17:03 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 17:03:38 EST
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stelios Kousouris 2015-12-15 11:06:46 EST
Description of problem:

In this JIRA https://issues.jboss.org/browse/JBDVPL-287 we provide spatial functions for DV to DB downstream running of these functions. The aim would be to allow VDBs to expose geospatial function execution on the views by the clients

RWS a Dutch agency which manages bridges etc. and their maintenance in The Netherlands utilizes WMS/WFS web services implemented by ArcGIS, Geoserver, MapServer, QGIS to locate places of interest (bridges) on map along with their features. To achieve this we need to integrate and run geospatial functions on the backends (some are already planned in for 6.3) but since the consuming clients require WMS/WFS input we would require DV to also expose the geospatial functions via the JDBC/ODBC drivers to the client apps (ArcGIS, Geoserver etc.). Hence DV VDBs would need to appear GIS compliant datasources.
Comment 1 Van Halbert 2015-12-15 11:15:24 EST
Do you have details on what it means to be GIS compliant?
Comment 2 Cojan van Ballegooijen 2015-12-15 13:38:56 EST
See 

http://www.esri.com/~/media/Files/Pdfs/library/whitepapers/pdfs/supported-ogc-iso-standards.pdf

WMS - http://www.opengeospatial.org/standards/wms
WFS - http://www.opengeospatial.org/standards/wfs

RWS is using MapViewer to show maps based on WMS services. The WMS services are provided by a GeoServer like ArcGIS or GeoServer. 

OData has also some capabilities in the Geo space especially on the .Net libraries side.
See http://www.odata.org/libraries/ for Microsoft.Spatial (OData v4) and System.Spatial (OData v1-3)
Comment 3 Van Halbert 2015-12-21 17:03:38 EST
Closing as this has been logged in product planning.

Note You need to log in before you can comment on or make changes to this bug.