Bug 129185 - Running tc, dmesg complains after updating to 2.6.7-1.494.2.2
Running tc, dmesg complains after updating to 2.6.7-1.494.2.2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: iproute (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks: FC2Update
  Show dependency treegraph
 
Reported: 2004-08-04 17:14 EDT by jar
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-02 15:50:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jar 2004-08-04 17:14:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
After updating to 2.6.7-1.494.2.2 the tc commands are complaining. 
Dmesg says:

HTB init, kernel part version 3.16

RTNETLINK answers: Invalid argument
RTNETLINK answers: Invalid argument
RTNETLINK answers: Invalid argument
RTNETLINK answers: Invalid argument
RTNETLINK answers: Invalid argument
RTNETLINK answers: Invalid argument
RTNETLINK answers: Invalid argument
...
...
Please upgrade your iproute2 tools or compile proper options in!
Please upgrade your iproute2 tools or compile proper options in!
Please upgrade your iproute2 tools or compile proper options in!
Please upgrade your iproute2 tools or compile proper options in!
...
...


Version-Release number of selected component (if applicable):
iproute-2.4.7-14

How reproducible:
Always

Steps to Reproduce:
1. Run any shell script which contains tc commands
2.
3.
    

Actual Results:  Dmesg complains:

HTB init, kernel part version 3.16
RTNETLINK answers: Invalid argument
RTNETLINK answers: Invalid argument
Please upgrade your iproute2 tools or compile proper options in!
Please upgrade your iproute2 tools or compile proper options in!



Expected Results:  Dmesg just say: HTB init, kernel part version 3.16


Additional info:
Comment 1 Chris Adams 2004-08-11 00:19:25 EDT
Either CLS_U32_PERF needs to be disabled when building the kernel or
the iproute utils need to be upgraded.  Until then, traffic shaping
with FC2 is broken because you can't set rules.
Comment 2 Warren Togami 2004-08-11 02:14:22 EDT
Arjan would you rather us back out this option from the next FC2
kernel update, or issue a new version of iproute?
Comment 3 Kenneth Porter 2004-08-11 02:22:52 EDT
From the config help for that option:

gathers stats that could be used to tune u32 classifier performance.

That doesn't sound like something that needs to be in a stock kernel,
esp. now that FC3 is under construction. It might make more sense to
defer it to FC3.
Comment 4 Warren Togami 2004-08-11 19:38:49 EDT
Arjan told me that this should be fixed in newer kernels, and we need
a newer kernel in FC2 updates "soon" for bug fix reasons.  In the mean
time please test the rawhide kernels.  Is this working there?
Comment 5 Chris Adams 2004-08-11 21:32:05 EDT
I just tried kernel-smp-2.6.7-1.515.i686.rpm and it looks like it
works okay there.  Thanks.
Comment 6 Nathan G. Grennan 2004-08-14 20:20:35 EDT
This bug is a duplicate of 128543, and the issue is still not
completely fixed.
Comment 7 Radek Vokal 2004-09-02 04:45:27 EDT
According to Stephen Hemminger <shemminger@osdl.org>

"The general policy is that iproute2-<version> contains all the
features in the API for that kernel version.  It should build and run
on older and newer kernels with the obvious caveat that the command
can only support what the kernel does."

So for 2.6.x kernel you'd better use iproute-2.6.x (curently in
development tree) 

Note You need to log in before you can comment on or make changes to this bug.