Bug 1291860 - Packaged old version (1.06) of kubernetes in most recent release. kubernetes rpm labeled 1.1xxxx
Packaged old version (1.06) of kubernetes in most recent release. kubernetes ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kubernetes (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jan Chaloupka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 13:05 EST by Kiran Nagaraja
Modified: 2016-03-31 20:28 EDT (History)
10 users (show)

See Also:
Fixed In Version: kubernetes-1.2.0-0.4.alpha1.git4c8e6f4.fc23 kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 20:28:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kiran Nagaraja 2015-12-15 13:05:39 EST
Description of problem:

We just upgraded to the latest Fedora Atomic by doing 'rpm-ostree upgrade’ starting from a base Fedora 23 Atomic. kernel version (and other packages) after upgrade seem as reported below:
http://www.projectatomic.io/blog/2015/12/fedora-atomic-host-two-week-release-ready/

However, the kubernetes binaries report git version v1.06,  while the rpm is packaged as 1.1. ' kubernetes-1.1.0-0.17.git388061f.fc23.x86_64’. Since kub 1.1 has been out, it would make sense to push that out, and also correct the labeling as it's confusing.


Version-Release number of selected component (if applicable):
Febdora 23 Atomic Host 

How reproducible:
install Fedora 23 qcow2 image, run 'rpm-ostree upgrade', reboot and check kubernetes binary versions using kubectl or kubelet

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jan Chaloupka 2016-01-07 07:12:56 EST
The current stability of kubernetes is still in a question. The current kubernetes is built from openshift's source codes. More precisely, from source code in Godeps/_workspace/src/k8s.io/kubernetes directory which replaces the current kubernetes code. It is pure kubernetes + patches no yet in upstream. The aim is to provide more stable component and to be as much close as possible to the latest release.

In general, kubernetes in Fedora miss proper testing which would discover regressions and other issues. I will provide the latest build we have in rawhide branch. However, it will be kept in updates-testing for quite some time before it gets proper testing. So any test you can run on kubernetes is welcomed.
Comment 2 Fedora Update System 2016-01-07 08:37:18 EST
kubernetes-1.2.0-0.4.alpha1.git4c8e6f4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-57b96b46e3
Comment 3 Kiran Nagaraja 2016-01-07 13:34:41 EST
Jan, thanks, good to see the progress. I'm wondering why not package a main repo release version, like v1.1.3?(In reply to Jan Chaloupka from comment #1)

> The current stability of kubernetes is still in a question. The current
> kubernetes is built from openshift's source codes. More precisely, from
> source code in Godeps/_workspace/src/k8s.io/kubernetes directory which
> replaces the current kubernetes code. It is pure kubernetes + patches no yet
> in upstream. The aim is to provide more stable component and to be as much
> close as possible to the latest release.
> 
> In general, kubernetes in Fedora miss proper testing which would discover
> regressions and other issues. I will provide the latest build we have in
> rawhide branch. However, it will be kept in updates-testing for quite some
> time before it gets proper testing. So any test you can run on kubernetes is
> welcomed.
Comment 4 Jan Chaloupka 2016-01-08 02:23:46 EST
> Jan, thanks, good to see the progress. I'm wondering why not package a main
> repo release version, like v1.1.3?(In reply to Jan Chaloupka from comment #1)

Due to a lack of more powerful integration testing. In future, it can change.
Comment 5 Fedora Update System 2016-01-08 23:28:27 EST
kubernetes-1.2.0-0.4.alpha1.git4c8e6f4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-57b96b46e3
Comment 6 Fedora Update System 2016-02-29 12:29:25 EST
kubernetes-1.2.0-0.12.alpha6.gitf0cd09a.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5a203fd7ac
Comment 7 Fedora Update System 2016-02-29 18:52:03 EST
kubernetes-1.2.0-0.12.alpha6.gitf0cd09a.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5a203fd7ac
Comment 8 Fedora Update System 2016-03-01 04:10:17 EST
kubernetes-1.2.0-0.13.alpha6.gitf0cd09a.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8bc7ba5f6b
Comment 9 Fedora Update System 2016-03-02 07:53:02 EST
kubernetes-1.2.0-0.13.alpha6.gitf0cd09a.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8bc7ba5f6b
Comment 10 Fedora Update System 2016-03-08 14:03:21 EST
kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a89f5ce5f4
Comment 11 Fedora Update System 2016-03-09 17:55:57 EST
kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a89f5ce5f4
Comment 12 Fedora Update System 2016-03-31 20:27:53 EDT
kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.