Bug 1291861 - Catalog Item : Editing a catalog item after deleting provider shows error
Catalog Item : Editing a catalog item after deleting provider shows error
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.5
Assigned To: lgalis
Shveta
service:catalog
: ZStream
Depends On: 1210541
Blocks: 1261968
  Show dependency treegraph
 
Reported: 2015-12-15 13:11 EST by John Prause
Modified: 2016-07-26 11:30 EDT (History)
10 users (show)

See Also:
Fixed In Version: 5.5.5.2
Doc Type: Bug Fix
Doc Text:
In a previous CloudForms version, editing a catalog item after deleting a provider resulted in an error. The error was raised during a check by miq_provision_virt_workflow.rb, which then prevented the user interface from loading the workflow. The code now checks an object's existence before calling a method on it and catalog items can be edited successfully.
Story Points: ---
Clone Of: 1210541
Environment:
Last Closed: 2016-07-26 11:30:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sshveta: automate_bug-


Attachments (Terms of Use)

  None (edit)
Comment 5 Shveta 2016-07-06 19:12:56 EDT
Still see the error in 5.5.5.0.20160628144838_629f93b
Comment 7 Shveta 2016-07-07 17:34:42 EDT
Hi , 

Please check https://10.16.5.163.
Catalog name "edit_catalog" .
Click on it to see the error .

Thanks ,
Shveta
Comment 11 Shveta 2016-07-15 14:44:47 EDT
Fixed .
verified in 5.5.5.2.20160712144556_629f93b
Comment 13 errata-xmlrpc 2016-07-26 11:30:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html

Note You need to log in before you can comment on or make changes to this bug.