Bug 1291867 - [conn] show progress when repo has metalink
[conn] show progress when repo has metalink
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 13:47 EST by Christian Stadelmann
Modified: 2017-06-16 09:18 EDT (History)
5 users (show)

See Also:
Fixed In Version: dnf-2.5.1-1.fc26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-16 09:18:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2015-12-15 13:47:59 EST
Description of problem:
Right now mirrors of rpmfusion seem to be suffering a high load. They barely respond to HTTP requests. When using dnf it freezes for minutes.

Version-Release number of selected component (if applicable):
dnf-1.1.4-2.fc23.noarch
hawkey-0.6.2-3.fc23.x86_64
libsolv-0.6.14-7.fc23.x86_64
rpm-4.13.0-0.rc1.7.fc23.x86_64

How reproducible:
I don't really know. Right now (with mirror offline) I can permanently reproduce this issue.

Steps to Reproduce:
1. start dnf with any action causing mirror refresh, e.g. `dnf upgrade`
2. wait.

Actual results:
For a very long time (~10 minutes) there is no response by dnf.

Expected results:
If a mirror is offline (and skip_if_unavailable is False, which is the case here) dnf should skip the mirror after some seconds (e.g. 5000 milliseconds). It should not blocking wait for minutes to connect to the mirror.

Additional info:
This issue also makes yumex-dnf (using dnf api) freeze on start in such cases.
Comment 1 Honza Silhan 2015-12-23 09:32:58 EST
(In reply to Christian Stadelmann from comment #0)
> If a mirror is offline and skip_if_unavailable is False
You probably meant True

Do you still have such problems? I believe these were temporary rpmfusion server issues. Can you try it again and set `timeout` dnf config value /etc/dnf/dnf.conf to lower value than default and post result, please?
Comment 2 Honza Silhan 2015-12-23 09:33:52 EST
+ attach the data described here [1], please.

[1] https://github.com/rpm-software-management/dnf/wiki/Bug-Reporting#connection-issue
Comment 3 Christian Stadelmann 2016-01-19 17:34:10 EST
> > If a mirror is offline and skip_if_unavailable is False
> You probably meant True

Yes, I meant True.

> 
> Do you still have such problems? I believe these were temporary rpmfusion
> server issues. Can you try it again and set `timeout` dnf config value
> /etc/dnf/dnf.conf to lower value than default and post result, please?
> + attach the data described here [1], please.
> 
> [1]
> https://github.com/rpm-software-management/dnf/wiki/Bug-Reporting#connection-
> issue

$ rpm -q librepo curl dnf
librepo-1.7.16-2.fc23.x86_64
curl-7.43.0-4.fc23.x86_64
dnf-1.1.5-1.fc23.noarch

I wasn't able to reproduce and the /var/log/dnf.librepo.log file doesn't have timestamps and has gone already.

Is it possible that the timeout (default: 30seconds) was just applied to each repo successively, maybe even two or three times per repo when retrying?
Comment 4 Honza Silhan 2016-01-25 07:14:39 EST
(In reply to Christian Stadelmann from comment #3)

> Is it possible that the timeout (default: 30seconds) was just applied to
> each repo successively, maybe even two or three times per repo when retrying?

The timeout is for one repo.
Comment 5 Christian Stadelmann 2016-01-25 09:14:51 EST
Ok, that probably has been the cause then. With 6 rpmfusion repos enabled it waited at least 3 minutes.
Comment 6 Fedora Admin XMLRPC Client 2016-07-08 05:35:37 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Jaroslav Mracek 2017-05-23 11:04:10 EDT
Ok, a have found that timeout in dnf is set to 120 s and it differs from yum. I create PR that changed it to 30 s like in yum (https://github.com/rpm-software-management/dnf/pull/824). Probably it helps. The showing a progress if used metalink it would be tricky, because we use at the same time 3 downloads in parallel and each of downloads could be handled from different server. But probably we will improve that also in future.
Comment 8 Fedora Update System 2017-06-12 11:29:51 EDT
dnf-plugins-core-2.1.1-1.fc26 libdnf-0.9.1-1.fc26 dnf-2.5.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c87c47dccb
Comment 9 Fedora Update System 2017-06-13 21:35:41 EDT
dnf-2.5.1-1.fc26, dnf-plugins-core-2.1.1-1.fc26, libdnf-0.9.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c87c47dccb
Comment 10 Fedora Update System 2017-06-14 01:33:46 EDT
dnf-2.5.1-1.fc26 dnf-plugins-core-2.1.1-1.fc26 dnfdaemon-0.3.18-3.fc26 libdnf-0.9.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c87c47dccb
Comment 11 Fedora Update System 2017-06-15 09:55:52 EDT
dnf-2.5.1-1.fc26, dnf-plugins-core-2.1.1-1.fc26, dnfdaemon-0.3.18-3.fc26, libdnf-0.9.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c87c47dccb
Comment 12 Fedora Update System 2017-06-16 09:18:42 EDT
dnf-2.5.1-1.fc26, dnf-plugins-core-2.1.1-1.fc26, dnfdaemon-0.3.18-3.fc26, libdnf-0.9.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.