This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1291885 - Version of pngquant in EPEL6 is debug version
Version of pngquant in EPEL6 is debug version
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: pngquant (Show other bugs)
el6
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Sergio Monteiro Basto
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 14:37 EST by freeyourmind
Modified: 2016-01-15 02:23 EST (History)
2 users (show)

See Also:
Fixed In Version: pngquant-2.5.2-5.fc23 pngquant-2.5.2-5.fc22 pngquant-2.5.2-5.el7 pngquant-2.5.2-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 17:54:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description freeyourmind 2015-12-15 14:37:55 EST
Description of problem:
The version of pngquant in EPEL6 is the debug version. The debug version is considerably slower than the production version.


Version-Release number of selected component (if applicable):
pngquant-2.4.1-1.el6.x86_64.rpm


How reproducible:
100% reproducible

Steps to Reproduce:
1. Install pngquant
2. Run pngquant without parameters
3. Look at top of output, see "DEBUG (slow) version."

Actual results:
pnquant, with no parameters, prints:
pngquant, 2.4.1 (April 2015), by Greg Roelofs, Kornel Lesinski.
   DEBUG (slow) version.
   Compiled with SSE instructions.
   Using libpng 1.2.49 with Little CMS color profile support.


Expected results:
We don't want to see the DEBUG line:
pngquant, 2.4.1 (April 2015), by Greg Roelofs, Kornel Lesinski.
   Compiled with SSE instructions.
   Using libpng 1.2.49 with Little CMS color profile support.


Additional info:
This line is probably the culprit:
http://pkgs.fedoraproject.org/cgit/pngquant.git/tree/pngquant.spec#n69

"--enable-debug" is not what we want.
Comment 1 Fedora Update System 2015-12-19 17:57:34 EST
pngquant-2.5.2-5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-75195bd133
Comment 2 Fedora Update System 2015-12-19 17:58:13 EST
pngquant-2.5.2-5.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-4a647a067b
Comment 3 Fedora Update System 2015-12-19 18:01:10 EST
pngquant-2.5.2-5.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-c2d2f37740
Comment 4 Fedora Update System 2015-12-19 18:01:44 EST
pngquant-2.5.2-5.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8ec0a54524
Comment 5 Sergio Monteiro Basto 2015-12-19 21:18:32 EST
I finally found where I went wrong , pngquant don't have a standard ./configure so we can't use %configure (rpm macro), without %configure, CFLAGS wasn't set to the default of rpms , so I used --enable-debug to enable -g compile flag , but the problem was not use %configure because with %configure, set -g compile flag. 
We need -g to generate correctly debuginfo packages. 
Thanks for your report, it helped to find this mystery in my head.
Comment 6 Fedora Update System 2015-12-20 06:22:40 EST
pngquant-2.5.2-5.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update pngquant'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8ec0a54524
Comment 7 Fedora Update System 2015-12-20 06:25:00 EST
pngquant-2.5.2-5.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update pngquant'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-c2d2f37740
Comment 8 Fedora Update System 2015-12-20 06:55:55 EST
pngquant-2.5.2-5.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update pngquant'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-4a647a067b
Comment 9 Fedora Update System 2015-12-20 07:24:10 EST
pngquant-2.5.2-5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update pngquant'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-75195bd133
Comment 10 Fedora Update System 2015-12-28 17:54:48 EST
pngquant-2.5.2-5.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2015-12-28 18:51:49 EST
pngquant-2.5.2-5.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2016-01-15 01:55:29 EST
pngquant-2.5.2-5.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2016-01-15 02:23:16 EST
pngquant-2.5.2-5.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.