Bug 1291894 - Updating open-vm-tools fails when VMware's open-vm-tools-deploypkg is installed
Updating open-vm-tools fails when VMware's open-vm-tools-deploypkg is installed
Status: CLOSED DUPLICATE of bug 1290052
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: open-vm-tools (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On:
Blocks: 1203710
  Show dependency treegraph
 
Reported: 2015-12-15 15:09 EST by Cory Bosley
Modified: 2016-12-10 19:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 05:01:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cory Bosley 2015-12-15 15:09:59 EST
Description of problem:

Updating RHEL 7.1 to RHEL 7.2 fails on the update of Red Hat's open-vm-tools package when VMware's open-vm-tools-deploypkg package is installed. from http://packages.vmware.com/packages/rhel7/x86_64/index.html

Version-Release number of selected component (if applicable):

open-vm-tools-9.4.0-6.el7.x86_64
open-vm-tools-deploypkg-9.4.10-3.x86_64

How reproducible:

always

Steps to Reproduce:
1. Install open-vm-tools-9.4.0-6.el7.x86_64
2. Install open-vm-tools-deploypkg-9.4.10-3.x86_64 following instructions at http://partnerweb.vmware.com/GOSIG/RHEL_7.html
3. yum update --quiet

Actual results:

# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.1 (Maipo)
# rpm -qa | grep open-vm
open-vm-tools-9.4.0-6.el7.x86_64
open-vm-tools-deploypkg-9.4.10-3.x86_64
yum update --quiet
Error: Package: open-vm-tools-deploypkg-9.4.10-3.x86_64 (installed)
           Requires: open-vm-tools < 9.5
           Removing: open-vm-tools-9.4.0-6.el7.x86_64 (@anaconda/7.1)
               open-vm-tools = 9.4.0-6.el7
           Updated By: open-vm-tools-9.10.2-4.el7.x86_64 (rhel-x86_64-server-7)
               open-vm-tools = 9.10.2-4.el7
           Available: open-vm-tools-9.4.0-3.el7.x86_64 (rhel-x86_64-server-7)
               open-vm-tools = 9.4.0-3.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:

No dependency errors.

Additional info:

Caused by the fix for https://bugzilla.redhat.com/show_bug.cgi?id=1172833
https://rhn.redhat.com/errata/RHBA-2015-2246.html

It looks like a new open-vm-tools-deploypkg package should have been created by Red Hat to replace the libraries in the old closed source open-vm-tools-deploypkg package.  Or maybe "Provides: open-vm-tools-deploypkg" in the spec file would work.
Comment 2 Terry Bowling 2015-12-18 15:06:12 EST
This is really an issue for VMware to answer and support as Red Hat does not know what all VMware provides in their private rpm packages.

VMware provides updates to the open-vm-tools community project to make it easier for Linux distributions to distribute.  As explained here:

	What is open-vm-tools?
	https://access.redhat.com/solutions/1694373

RHEL 7.2 provides a newer version of open-vm-tools and appears to provide most of the functionality of the *DeployPkg rpm.

It looks like you simply need to uninstall open-vm-tools-deploypkg before doing your update.

It is possible that yum/rpm could do this for you if open-vm-tools-10* included the "deprecates=open-vm-tools-deploypkg".  However, I am not sure that would be approved if not all of the functionality is there.

References:
   bz1269243
   bz1172833

Can you simply uninstall open-vm-tools-deploypkg to proceed with your updates?  Otherwise, you can manage your repository to include newer, proprietary versions provided by VMware rather than the Red Hat supported versions.

-Terry
Comment 3 Terry Bowling 2015-12-18 15:24:59 EST
Can Red Hat use a Provides or Deprecates tag so that the newer RHEL open-vm-tools will uninstall/replace the old open-vm-tools-deploypkg?
Comment 4 Ravindra Kumar 2016-01-04 15:05:08 EST
open-vm-tools 9.10.x and later provides all the functionality of open-vm-tools-deploypkg. So, if adding "provides=open-vm-tools-deploypkg" would remove the open-vm-tools-deploypkg package automatically, that would be ideal.
Comment 5 Ravindra Kumar 2016-01-12 14:30:56 EST
Isn't this duplicate of bug 1290052?

Looks like, we need to choose and implemented one tag from "obsoletes", "provides" and "deprecates" in open-vm-tools.spec.
Comment 6 ldu 2016-01-19 05:01:46 EST

*** This bug has been marked as a duplicate of bug 1290052 ***

Note You need to log in before you can comment on or make changes to this bug.