Bug 1291897 - install of compiz-xfce conflicts with emerald
Summary: install of compiz-xfce conflicts with emerald
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: emerald
Version: 22
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Wolfgang Ulbrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-15 20:15 UTC by George R. Goffe
Modified: 2015-12-31 01:50 UTC (History)
2 users (show)

Fixed In Version: emerald-0.8.9-3.fc23 emerald-0.8.9-3.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-31 00:55:53 UTC


Attachments (Terms of Use)

Description George R. Goffe 2015-12-15 20:15:24 UTC
Description of problem:

Attempting to install compiz-xfce. Received conflict with emerald. Removed emerald with "rpm --nodeps -e emerald". Attempted to install compiz-xfce but still received conflict msgs even though emerald is NOT in the system.

Version-Release number of selected component (if applicable):

see additional info below.

How reproducible:

see additional info below.

Steps to Reproduce:
1.
2.
3.

Actual results:

see additional info below.

Expected results:

see additional info below.

Additional info:

fc22-bash 4.3 ~# dnf install compiz-xfce.x86_64
Last metadata expiration check performed 2:20:50 ago on Tue Dec 15 09:48:31 2015.
Dependencies resolved.
===================================================================================================================================================================
 Package                                 Arch                               Version                                      Repository                           Size
===================================================================================================================================================================
Installing:
 compiz                                  x86_64                             1:0.8.8-29.fc22                              fedora                              946 k
 compiz-xfce                             x86_64                             1:0.8.8-29.fc22                              fedora                               14 k
 emerald                                 x86_64                             1:0.8.9-1.fc22                               updates                             346 k

Transaction Summary
===================================================================================================================================================================
Install  3 Packages

Total download size: 1.3 M
Installed size: 8.0 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): compiz-xfce-0.8.8-29.fc22.x86_64.rpm                                                                                         66 kB/s |  14 kB     00:00
(2/3): emerald-0.8.9-1.fc22.x86_64.rpm                                                                                             237 kB/s | 346 kB     00:01
(3/3): compiz-0.8.8-29.fc22.x86_64.rpm                                                                                             467 kB/s | 946 kB     00:02
-------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                              278 kB/s | 1.3 MB     00:04
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache till the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/applications/compiz-xfce-emerald.desktop conflicts between attempted installs of compiz-xfce-1:0.8.8-29.fc22.x86_64 and emerald-1:0.8.9-1.fc22.x86_64

Error Summary
-------------

fc22-bash 4.3 ~# rpm -q emerald
package emerald is not installed

Comment 1 Wolfgang Ulbrich 2015-12-15 20:31:03 UTC
compiz-xfce is obsolete, you don't need it anymore.
All scripts are now in emerald itself.
Simply use 'dnf install compiz emerald'.
Well, i will fix that obsolete stuff in next compiz and emerald rebuild.

Comment 2 Fedora Update System 2015-12-15 22:33:29 UTC
emerald-0.8.9-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-4a38486709

Comment 3 Fedora Update System 2015-12-16 14:50:50 UTC
emerald-0.8.9-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update emerald'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-a0553d3989

Comment 4 Fedora Update System 2015-12-17 01:59:35 UTC
emerald-0.8.9-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update emerald'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-4a38486709

Comment 5 Fedora Update System 2015-12-20 22:26:32 UTC
compiz-manager-0.7.0-2.fc23 emerald-0.8.9-3.fc23 fusion-icon-0.1.2-4.fc23 compiz-0.8.10-2.fc23 marco-1.12.1-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-155fbf7d55

Comment 6 Fedora Update System 2015-12-20 22:26:32 UTC
compiz-manager-0.7.0-2.fc22 emerald-0.8.9-3.fc22 fusion-icon-0.1.2-4.fc22 compiz-0.8.10-2.fc22 marco-1.12.1-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-166c19ee89

Comment 7 Fedora Update System 2015-12-22 15:33:48 UTC
compiz-0.8.10-2.fc22, compiz-manager-0.7.0-2.fc22, emerald-0.8.9-3.fc22, fusion-icon-0.1.2-4.fc22, marco-1.12.1-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-166c19ee89

Comment 8 George R. Goffe 2015-12-22 19:14:18 UTC
Wolfgang,

I have filed another bug on this site that might be related to this bug. It's id is: 1293236.

Would you be willing to take a look and possibly route it to the correct person?

Also, there is a kde-testing site whose repository is out of wack. Could you possibly look at that too please? Here's the indication:

Failed to synchronize cache for repo 'kde' from 'http://apt.kde-redhat.org/apt/kde-redhat/fedora/mirrors-stable': Yum repo downloading error: Downloading error(s): repodata/895d15182ff7a65a736d8de8f223ad2eea5624407160f6fd04fcc83dab5998aa-filelists.xml.gz - Cannot download, all mirrors were already tried without success; repodata/b8d92d86c095f68ff68f07c5239c62b6758b2a75c33569003b36febeb6e376be-primary.xml.gz - Cannot download, all mirrors were already tried without success, disabling.

I will also post a pointer to the new bug report on the bugs.kde.org site. https://bugs.kde.org/show_bug.cgi?id=357063

Thanks.

George...

Comment 9 Wolfgang Ulbrich 2015-12-22 19:45:33 UTC
I don't think that this is related to your report here.
I did make a mistake in packaging emerald which is fixed now.
What you posted looks like a dnf mirror issue.
Try 'dnf clean metadata' as root.

Comment 10 Fedora Update System 2015-12-23 00:11:16 UTC
compiz-0.8.10-2.fc23, compiz-manager-0.7.0-2.fc23, emerald-0.8.9-3.fc23, fusion-icon-0.1.2-4.fc23, marco-1.12.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-155fbf7d55

Comment 11 Fedora Update System 2015-12-31 00:55:49 UTC
compiz-0.8.10-2.fc23, compiz-manager-0.7.0-2.fc23, emerald-0.8.9-3.fc23, fusion-icon-0.1.2-4.fc23, marco-1.12.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-12-31 01:50:22 UTC
compiz-0.8.10-2.fc22, compiz-manager-0.7.0-2.fc22, emerald-0.8.9-3.fc22, fusion-icon-0.1.2-4.fc22, marco-1.12.1-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.