Bug 1291902 - Enable mlx5, ocrdma, and usnic in kernel builds
Enable mlx5, ocrdma, and usnic in kernel builds
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 15:34 EST by Doug Ledford
Modified: 2018-04-11 14:07 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-11 14:07:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Ledford 2015-12-15 15:34:02 EST
Description of problem:

The current Fedora kernel builds omit a number of current RDMA capable drivers.

Version-Release number of selected component (if applicable):

kernel-4.4.0-0.rc2.git1.1.fc24.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Install rawhide, try to use certain hardware
2.
3.

Actual results:

No modules built, hardware not supported

Expected results:

Hardware will work.

Additional info:

Please enable the following kernel options in the general config for the Fedora kernels, and preferably carry this change back to the f22 and f23 kernels as well:


CONFIG_MLX5_CORE=m
CONFIG_MLX5_CORE_EN=y
CONFIG_MLX5_INFINIBAND=m
CONFIG_MLX4_EN=m
CONFIG_MLX4_EN_DCB=y
CONFIG_MLX4_EN_VXLAN=y
CONFIG_MLX4_CORE=m
# CONFIG_MLX4_DEBUG is not set (could be enabled though, not high priority either way)
CONFIG_MLX4_INFINIBAND=m
CONFIG_CHELSIO_T4=m
CONFIG_CHELSIO_T4_DCB=y
# CONFIG_CHELSIO_T4_FCOE is not set (I've seen this one cause boot hangs, best to leave off for now)
CONFIG_CHELSIO_T4VF=m
CONFIG_INFINIBAND_OCRDMA=m
CONFIG_INFINIBAND_USNIC=m
Comment 1 Laura Abbott 2015-12-16 16:23:25 EST
I turned the options on in rawhide. Once they've gotten some testing there we can make a decision on backporting to F22 or F23.
Comment 2 Doug Ledford 2015-12-17 13:03:59 EST
When it comes time to make the decision on f22/f23, please keep in mind that I am the upstream maintainer of the RDMA stack in the linux kernel, that all of these drivers are related to my upstream activities, and the fact that these are turned off is a hindrance to me being able to perform testing using fedora as a platform in the internal RDMA dedicated lab at Red Hat where all of the hardware that I requested be enabled is present and used.  That being the case, I hope you can get this hardware enabled across the board, and preferably sooner rather than later.
Comment 3 Josh Boyer 2015-12-17 14:47:34 EST
I'm curious why you're only requesting them to be enabled now if this is a hinderance to testing.
Comment 4 Doug Ledford 2015-12-17 14:51:41 EST
Because for the last couple years I've been highly focused on RHEL support (this was prior to taking over for the previous upstream kernel maintainer of the RDMA stack).  Since taking over as the upstream maintainer, people have been brought in to backfill my RHEL responsibilities, and I'm focused entirely on upstream.  In that regard, I would prefer to use fedora as my base platform for that work, but I need these options enabled to make the transition from using RHEL7 as my base platform.
Comment 5 Neil Horman 2017-12-19 13:04:54 EST
FWIW, mlx5 is a converged adapter that would be super helpful to enable in Feodra, for Ethernet work.

though, this has been open for two years now.  Why is it still disabled?
Comment 6 Laura Abbott 2017-12-19 13:59:42 EST
I'm looking at rawhide and the options are enabled as well as F27 (see https://git.kernel.org/pub/scm/linux/kernel/git/jwboyer/fedora.git/commit/?h=f27&id=04efbf7ae96008fdab54fc3e2c15be69223f5b50) where are you seeing them disabled?
Comment 7 Laura Abbott 2018-04-06 14:53:34 EDT
Do we still need to set options?
Comment 8 Doug Ledford 2018-04-07 21:13:02 EDT
I checked the x86_64 config.  The mlx5 is enabled now, but some new options have come up in the meantime that should be enabled:

+# CONFIG_SMC is not set
+# CONFIG_INFINIBAND_QEDR is not set
+# CONFIG_INFINIBAND_BNXT_RE is not set

On aarch64:

+# CONFIG_NET_VENDOR_HUAWEI is not set

Without that set, we don't even see the option for HNS_ROCE under the infiniband drivers.
Comment 9 Laura Abbott 2018-04-09 13:31:16 EDT
Did you mean NET_VENDOR_HISILICON?
Comment 10 Laura Abbott 2018-04-11 14:07:07 EDT
I turned on the ones that were still listed as being off, so I'm going to close this particular bug. Feel free to open a new bug for other options you find that are off or submit a patch to kernel@lists.fedoraproject

Note You need to log in before you can comment on or make changes to this bug.