Bug 1291905 - Unable to deploy Drupal
Unable to deploy Drupal
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Vu Dinh
XiuJuan Wang
:
Depends On:
Blocks: 1308720
  Show dependency treegraph
 
Reported: 2015-12-15 15:48 EST by Vu Dinh
Modified: 2017-05-31 14:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1308720 (view as bug list)
Environment:
Last Closed: 2017-05-31 14:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vu Dinh 2015-12-15 15:48:04 EST
Description of problem:
Unable to deploy Drupal application using drupal-quickstart due to Drush installation failure

Version-Release number of selected component (if applicable):


How reproducible:
Create an Drupal application using drupal-quickstar from github.

Steps to Reproduce:
1. rhc app create drupal php-5.3 mysql-5.1 cron --from-code=git://github.com/openshift/drupal-quickstart.git
2.
3.

Actual results:
Output shows Drush cannot be installed via PEAR:

Creating application 'drupal' ... 
The initial build for the application failed: Shell command '/sbin/runuser -s /bin/sh 56707b294e70736a2d00002e -c "exec /usr/bin/runcon 'unconfined_u:system_r:openshift_t:s0:c0,c1000' /bin/sh -c \"gear
postreceive --init >> /tmp/initial-build.log 2>&1\""' returned an error. rc=255

.Last 10 kB of build output:
Stopping Cron cartridge
Stopping MySQL 5.1 cartridge
Stopping PHP 5.3 cartridge (Apache+mod_php)
Repairing links for 1 deployments
Building git ref 'master', commit 828f03d
Checking .openshift/pear.txt for PEAR dependency...
Checking PEAR: pear.drush.org/drush

Attempting to discover channel "pear.drush.org"...
Attempting fallback to https instead of http on channel "pear.drush.org"...
unknown channel "pear.drush.org" in "pear.drush.org/drush"
invalid package name/package file "pear.drush.org/drush"
install failed
An error occurred executing 'gear postreceive' (exit code: 1)
Error message: CLIENT_ERROR: Failed to execute: 'control build' for /var/lib/openshift/56707b294e70736a2d00002e/php

Expected results:
Application should have been created successfully.


Additional info:
This issue is due to PEAR installation for Drush is no longer supported. Here is the link to the issue: https://github.com/openshift/drupal-quickstart/issues/31
Comment 2 XiuJuan Wang 2016-01-11 21:59:46 EST
Works for drupal with php-5.3&mysql-5.1 and php-5.4&mysql-5.5 in devenv-5753

Counting objects: 3, done.
Delta compression using up to 2 threads.
Compressing objects: 100% (2/2), done.
Writing objects: 100% (2/2), 251 bytes, done.
Total 2 (delta 1), reused 0 (delta 0)
remote: Stopping Cron cartridge
remote: Stopping MySQL 5.5 cartridge
remote: Stopping PHP 5.4 cartridge (Apache+mod_php)
remote: Waiting for stop to finish
remote: Waiting for stop to finish
remote: Waiting for stop to finish
remote: Building git ref 'master', commit 936f098
remote: Checking .openshift/pear.txt for PEAR dependency...
remote: Checking composer.json for Composer dependency... 
remote: Warning: This development build of composer is over 30 days old. It is recommended to update it by running "/var/lib/openshift/569469ec5f37571955000026/php/usr/bin/composer self-update" to get the latest version.
remote: Loading composer repositories with package information
remote: Installing dependencies (including require-dev)
remote:   - Installing pear/console_table (1.2.1)
remote:     Loading from cache
remote: 
remote:   - Installing symfony/polyfill-mbstring (v1.0.1)
remote:     Loading from cache
remote: 
remote:   - Installing symfony/var-dumper (v2.8.1)
remote:     Loading from cache
remote: 
remote:   - Installing symfony/yaml (v2.8.1)
remote:     Loading from cache
remote: 
remote:   - Installing d11wtq/boris (v1.0.10)
remote:     Loading from cache
remote: 
remote:   - Installing drush/drush (7.1.0)
remote:     Loading from cache
remote: 
remote: pear/console_table suggests installing pear/Console_Color2 (>=0.1.2)
remote: symfony/var-dumper suggests installing ext-symfony_debug ()
remote: Writing lock file
remote: Generating optimized autoload files
remote: 
remote: Drupal is already installed at /var/lib/openshift/569469ec5f37571955000026/app-root/data/downloads/drupal-7.41
remote: 
remote: Preparing build for deployment
remote: Deployment id is f9c584f9
remote: Activating deployment
remote: Starting Cron cartridge
remote: Starting MySQL 5.5 cartridge
remote: Drupal is already configured.  Delete settings.php to rerun setup
remote: 
remote: Starting PHP 5.4 cartridge (Apache+mod_php)
remote: Application directory "php/" selected as DocumentRoot
remote: -------------------------
remote: Git Post-Receive Result: success
remote: Activation status: success
remote: Deployment completed with status: success
To ssh://569469ec5f37571955000026@drupal54-xiuwang.dev.rhcloud.com/~/git/drupal54.git/
   8152ed0..936f098  master -> master
Comment 3 Eric Paris 2017-05-31 14:22:11 EDT
We apologize, however, we do not plan to address this report at this time. The majority of our active development is for the v3 version of OpenShift. If you would like for Red Hat to reconsider this decision, please reach out to your support representative. We are very sorry for any inconvenience this may cause.

Note You need to log in before you can comment on or make changes to this bug.