Bug 1291907 - mangled config in /etc/sysconfig/init
mangled config in /etc/sysconfig/init
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts (Show other bugs)
6.7
s390x Linux
low Severity low
: rc
: 6.7
Assigned To: Lukáš Nykrýn
Leos Pol
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 15:52 EST by Neal Kim
Modified: 2016-11-25 08:08 EST (History)
2 users (show)

See Also:
Fixed In Version: initscripts-9.03.50-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 21:07:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0951 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2016-05-10 18:56:20 EDT

  None (edit)
Description Neal Kim 2015-12-15 15:52:25 EST
Description of problem:

Mangled config in /etc/sysconfig/init.

Looks like this:

 # Set to anything other than 'no' to allow hotkey interactive startup...
 PROMPT=yes
 # Set to 'yes' to allow probing for devices with swap signatures
# Set to anything other than 'no' to allow hotkey interactive startup...
PROMPT=no

Should look like this:

# Set to anything other than 'no' to allow hotkey interactive startup...
PROMPT=yes
# Set to 'yes' to allow probing for devices with swap signatures
AUTOSWAP=no


Version-Release number of selected component (if applicable):

initscripts-9.03.49-1.el6.s390x.rpm


How reproducible:

Always.


Steps to Reproduce:

1. Open /etc/sysconfig/init
2. Observe mangled config


Actual results:

Mangled config.

 # Set to anything other than 'no' to allow hotkey interactive startup...
 PROMPT=yes
 # Set to 'yes' to allow probing for devices with swap signatures
# Set to anything other than 'no' to allow hotkey interactive startup...
PROMPT=no


Expected results:

# Set to anything other than 'no' to allow hotkey interactive startup...
PROMPT=yes
# Set to 'yes' to allow probing for devices with swap signatures
AUTOSWAP=no


Additional info:

Interestingly enough the mangled config only appears in the s390x and PPC variants of RHEL 6. It looks like the config was mangled starting in RHEL 6.6.
Comment 1 Lukáš Nykrýn 2015-12-16 04:08:15 EST
The shipped configuration files  looks fine. Maybe something is changing them? Lets try anaconda.
Comment 2 David Cantrell 2015-12-17 11:39:46 EST
anaconda does not modify /etc/sysconfig/init
Comment 3 Neal Kim 2015-12-18 12:43:52 EST
Just FYI. If you extract the init script via rpm2cpio etc... you will see that the config is mangled right off the bat. Only the s390x and PPC variants as mentioned in the description.


Cheers,
Comment 4 Lukáš Nykrýn 2015-12-25 05:20:24 EST
Sorry my bad. This was broken by this commit https://git.fedorahosted.org/cgit/initscripts.git/commit/?id=7e7ab260

So yep, lets fix it.
Comment 7 Leos Pol 2016-02-16 05:54:30 EST
initscripts-9.03.49-1.el6 for s390 & s390x /etc/sysconfig/init contains
...
 # Set to anything other than 'no' to allow hotkey interactive startup...
 PROMPT=yes
 # Set to 'yes' to allow probing for devices with swap signatures
# Set to anything other than 'no' to allow hotkey interactive startup...
PROMPT=no
...

initscripts-9.03.50-1.el6 for s390 & s390x /etc/sysconfig/init contains
...
# Set to anything other than 'no' to allow hotkey interactive startup...
PROMPT=no
...

Other archs have different source and are not affected by this change.
Comment 9 errata-xmlrpc 2016-05-10 21:07:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0951.html

Note You need to log in before you can comment on or make changes to this bug.