Bug 1291922 - VM vendor column for Azure VMs is incorrectly set
VM vendor column for Azure VMs is incorrectly set
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Bill Wei
Jeff Teehan
ui:vm:provider:azure
:
Depends On:
Blocks: 1292147
  Show dependency treegraph
 
Reported: 2015-12-15 17:11 EST by Greg McCullough
Modified: 2016-06-29 11:21 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1292147 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:21:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg McCullough 2015-12-15 17:11:07 EST
Description of problem:
The vendor property of a VM should be unique per provider and needs to be set in the database as a lower-cased value.

Version-Release number of selected component (if applicable): 5.5.0


How reproducible: Always


Steps to Reproduce:
1. Configure an Azure provider and refresh so VMs and Templates are collected
2. From the rails console load an Azure VM
   v = ManageIQ::Providers::Azure::CloudManager::Vm.first
3. Evaluate the setting for vendor (which can be directly from the db column or through a method on the model):
1) DB column access:
  v.attributes["vendor"]
  => "Microsoft"
2) Model method:
  v.vendor
  => nil

Actual results:
  DB column returns "Microsoft"
  Model method returns nil

Expected results:
  DB column returns "azure" 
  Model method returns "Azure"

Additional info:
Comment 3 Greg McCullough 2015-12-16 09:16:49 EST
Opened based on PR discussion https://github.com/ManageIQ/manageiq/pull/5717#discussion-diff-47688376
Comment 4 Greg McCullough 2015-12-17 13:41:56 EST
Reproduction steps are incorrect.  The vendor column is properly set to a lower-case value but the value should be set to "azure" and not "microsoft".
Comment 5 CFME Bot 2015-12-23 10:00:57 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/ea9d594a7a931e68fb21f5ce636f27a408a12d99

commit ea9d594a7a931e68fb21f5ce636f27a408a12d99
Author:     Bill Wei <bilwei@redhat.com>
AuthorDate: Tue Dec 15 17:02:12 2015 -0500
Commit:     Bill Wei <bilwei@redhat.com>
CommitDate: Tue Dec 15 18:14:29 2015 -0500

    Change vendor names to azure
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1291922

 app/models/manageiq/providers/azure/cloud_manager/refresh_parser.rb | 4 ++--
 .../models/manageiq/providers/azure/cloud_manager/refresher_spec.rb | 6 +++---
 2 files changed, 5 insertions(+), 5 deletions(-)
Comment 6 CFME Bot 2015-12-23 15:48:37 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=f7b0ae2fb1e91bdf7047eb41fec07517d55d5f1f

commit f7b0ae2fb1e91bdf7047eb41fec07517d55d5f1f
Author:     Bill Wei <bilwei@redhat.com>
AuthorDate: Tue Dec 15 17:02:12 2015 -0500
Commit:     Bill Wei <bilwei@redhat.com>
CommitDate: Wed Dec 23 13:26:00 2015 -0500

    Change vendor names to azure
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1291922

 app/models/manageiq/providers/azure/cloud_manager/refresh_parser.rb | 4 ++--
 .../models/manageiq/providers/azure/cloud_manager/refresher_spec.rb | 6 +++---
 2 files changed, 5 insertions(+), 5 deletions(-)
Comment 7 Jeff Teehan 2016-03-29 10:57:15 EDT
Container now reads azure.  Moving to verified.
Tested on 5.6 Beta 1 using https://10.16.6.154/vm_cloud/explorer
Comment 9 errata-xmlrpc 2016-06-29 11:21:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.