Bug 1291935 - [RFE] support for Parametized Subnets
[RFE] support for Parametized Subnets
Status: ON_QA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Unspecified
Unspecified Unspecified
medium Severity medium (vote)
: GA
: --
Assigned To: Ohad Levy
Katello QA List
http://projects.theforeman.org/issues...
: FutureFeature, Triaged
Depends On:
Blocks: 1454583
  Show dependency treegraph
 
Reported: 2015-12-15 17:39 EST by John Fulton
Modified: 2017-08-15 16:13 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 1464 None None None 2016-12-12 08:01 EST
Foreman Issue Tracker 3582 None None None 2016-12-12 07:20 EST

  None (edit)
Description John Fulton 2015-12-15 17:39:10 EST
My customer wants subnets to have parameters the same way that hosts in Satellite 6 have parameters. 

For example, in the Foreman GUI:

 Hosts > All hosts > $host > YAML  

Displays "classes" for Puppet as well as "parameters" and those parameters can be modified by using the GUI to navigate: 

 Hosts > All hosts > $host > Edit > Parameters > Host Parameters

He would like to be able to use the Satellite GUI similarly to navigate: 

 Infrastructure > Subnets > $subnet > Parameters 

Though the "parameters tab is missing from subnets edit view" (from his perspective and thus this RFE).  

His use-case is for the following to happen:

 If a host's primary interface is assigned to a subnet, then the physical location information from that subnet is inherited by that host. 

So he would use the new "subnet parameters" to store location information for that subnet and then any host would inherit that information. 

Because he doesn't yet have this feature, his workaound is to store the location information in every host (which already supports parameters).
Comment 1 John Fulton 2015-12-15 17:42:29 EST
Is it possible for the host inheritance usecase described above to be addressed by what was proposed in the following upstream issue? 

 http://projects.theforeman.org/issues/1464
Comment 4 Bryan Kearney 2016-01-21 11:40:57 EST
Connecting redmine issue http://projects.theforeman.org/issues/1464 from this bug
Comment 7 Bryan Kearney 2016-07-08 16:37:31 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 9 Bryan Kearney 2016-08-23 16:11:10 EDT
Upstream bug assigned to ohadlevy@redhat.com
Comment 10 Bryan Kearney 2016-08-23 16:11:13 EDT
Upstream bug component is WebUI
Comment 11 Tomer Brisker 2016-12-12 07:20:46 EST
This has been resolved upstream in http://projects.theforeman.org/issues/3582 which is in Foreman 1.12. 
Moving to Post and aligning flags.

Note You need to log in before you can comment on or make changes to this bug.