Bug 1291979 - [ppc64le] Virtio-input support - qemu-kvm-rhev
Summary: [ppc64le] Virtio-input support - qemu-kvm-rhev
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: ppc64le
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Laurent Vivier
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1288337 RHV4.1PPC
TreeView+ depends on / blocked
 
Reported: 2015-12-16 06:22 UTC by Qunfang Zhang
Modified: 2016-11-07 21:46 UTC (History)
11 users (show)

Fixed In Version: qemu-kvm-rhev-2.5.0-1.el7
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 21:46:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description Qunfang Zhang 2015-12-16 06:22:14 UTC
Description of problem:

Create this bug to track the virtio-input related testing, currently the following devices shows up in the qemu-kvm device lists:

name "virtio-input-host-device", bus virtio-bus
name "virtio-input-host-pci", bus PCI
name "virtio-keyboard-device", bus virtio-bus
name "virtio-keyboard-pci", bus PCI
name "virtio-mouse-device", bus virtio-bus
name "virtio-mouse-pci", bus PCI
name "virtio-tablet-device", bus virtio-bus
name "virtio-tablet-pci", bus PCI

Please developer help adjust or fix something if they are not accurate.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Laurent Vivier 2016-02-23 14:06:22 UTC
I've checked they work with our qemu version:

name "virtio-keyboard-device", bus virtio-bus
name "virtio-keyboard-pci", bus PCI
name "virtio-mouse-device", bus virtio-bus
name "virtio-mouse-pci", bus PCI

They work fine.

I have tested them on text console and using gpm to test the mouse.

I've also checked them with Fedora 23 graphical installer and they work fine too, + the tablet device:

name "virtio-tablet-device", bus virtio-bus
name "virtio-tablet-pci", bus PCI

I'm not able to confirm "input-host" works as I have no physical access to a host.

Comment 5 mazhang 2016-06-23 07:44:16 UTC
Just got Gerd's reply , we can skip the virtio-input-host-pci test on ppc.

On Do, 2016-06-23 at 13:41 +0800, mazhang wrote:
> Hi Gerd,
>
> I met a problem when I test Bug 1291979 - [ppc64le] Virtio-input
> support - qemu-kvm-rhev.
> We can passthrough host keyboard/mouse to guest by
> virtio-input-host-pci.
> For guest pov, use host mouse to move pointer, and host keyboard for
> input.
> But we can't physical access a ppc host, any advise for test this
> device ?

Just skip the test on ppc then.

Comment 6 mazhang 2016-06-23 07:47:24 UTC
Hi Laurent,

Please help look at c#4 and c#5, does it sufficient for verify this bug?

Thanks,
Mazhang.

Comment 7 Laurent Vivier 2016-06-23 08:29:27 UTC
As endianness can differ between host and guest, we can have here bugs we don't have on x86_64.

But how this was tested for qemu-kvm-rhev-2.3.0?

Comment 8 mazhang 2016-06-23 09:09:04 UTC
(In reply to Laurent Vivier from comment #7)
> As endianness can differ between host and guest, we can have here bugs we
> don't have on x86_64.
> 
> But how this was tested for qemu-kvm-rhev-2.3.0?

Guess you mean Bug 1248933, actually we test on qemu-kvm-rhev-2.6.0-8.el7.ppc64le, see detail on 1248933#c10.

Comment 9 Laurent Vivier 2016-06-23 09:36:45 UTC
(In reply to mazhang from comment #8)
> (In reply to Laurent Vivier from comment #7)
> > As endianness can differ between host and guest, we can have here bugs we
> > don't have on x86_64.
> > 
> > But how this was tested for qemu-kvm-rhev-2.3.0?
> 
> Guess you mean Bug 1248933, actually we test on
> qemu-kvm-rhev-2.6.0-8.el7.ppc64le, see detail on 1248933#c10.

No, I mean: how virtio-input-host was tested for qemu-kvm-rhev-2.3.0?

But the code involved in virtio-input-host is only ~200 lines, so as Gerd has proposed, I think it is acceptable to only test this on x86_64 (as communication with host is done using generic ioctls through the event interface).

And I think user will have the same problematic we have: no physical access to the server.

So, just skip the test on ppc64le.

Comment 10 mazhang 2016-06-23 09:55:32 UTC
(In reply to Laurent Vivier from comment #9)
> (In reply to mazhang from comment #8)
> > (In reply to Laurent Vivier from comment #7)
> > > As endianness can differ between host and guest, we can have here bugs we
> > > don't have on x86_64.

I'll test BE guest and update result.

> > > 
> > > But how this was tested for qemu-kvm-rhev-2.3.0?
> > 
> > Guess you mean Bug 1248933, actually we test on
> > qemu-kvm-rhev-2.6.0-8.el7.ppc64le, see detail on 1248933#c10.
> 
> No, I mean: how virtio-input-host was tested for qemu-kvm-rhev-2.3.0?
> 

virtio-input not be tested for qemu-kvm-rhev-2.3.0

> But the code involved in virtio-input-host is only ~200 lines, so as Gerd
> has proposed, I think it is acceptable to only test this on x86_64 (as
> communication with host is done using generic ioctls through the event
> interface).
> 
> And I think user will have the same problematic we have: no physical access
> to the server.
> 
> So, just skip the test on ppc64le.

Comment 11 mazhang 2016-06-29 08:36:32 UTC
Test this bug with RHEL7.3 GE guest.

Host:
3.10.0-456.el7.ppc64le
qemu-kvm-rhev-2.6.0-10.el7.ppc64le

Guest:
3.10.0-456.el7.ppc64

No new bugs found.

Base on comment#4 comment#5 and above comment set this bug as verified, if any problem please let me know, thanks.

Comment 13 errata-xmlrpc 2016-11-07 21:46:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.