Bug 1292016 - Build python-setuptools_scm for the other branch
Build python-setuptools_scm for the other branch
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-setuptools_scm (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
https://github.com/pypa/setuptools_sc...
:
Depends On: 1294856
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 03:30 EST by Pierre-YvesChibon
Modified: 2016-02-10 06:13 EST (History)
1 user (show)

See Also:
Fixed In Version: python-setuptools_scm-1.10.1-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 06:13:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre-YvesChibon 2015-12-16 03:30:14 EST
Looking at koji:
http://koji.fedoraproject.org/koji/packageinfo?packageID=21210
and bodhi:
https://bodhi.fedoraproject.org/updates/?packages=python-setuptools_scm

It seems that python-setuptools_scm was only ever built for F23+ while it has branches for el6, epel7 and F22 as well.
Could we build python-setuptools_scm for these branches?
Comment 1 Orion Poplawski 2015-12-17 12:23:54 EST
Do you have actual package dependencies on all of those branches?
Comment 2 Fedora Update System 2016-01-04 13:35:56 EST
python-setuptools_scm-1.10.1-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-dc9e00756d
Comment 3 Orion Poplawski 2016-01-04 13:37:11 EST
Looks like python-setuptools is too old in EL7 (and presumably in EL6).  I may do a python3 only version in EL7.
Comment 4 Orion Poplawski 2016-01-04 13:37:57 EST
https://github.com/pypa/setuptools_scm/issues/73
Comment 5 Fedora Update System 2016-01-05 19:25:05 EST
python-setuptools_scm-1.10.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-dc9e00756d
Comment 6 Fedora Update System 2016-01-05 19:29:50 EST
python-setuptools_scm-1.10.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-abedcb64ad
Comment 7 Fedora Update System 2016-01-13 00:22:07 EST
python-setuptools_scm-1.10.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2016-01-13 01:23:54 EST
python-setuptools_scm-1.10.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2016-01-23 23:36:35 EST
python-setuptools_scm-1.10.1-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-83ef8ccea4
Comment 10 Fedora Update System 2016-01-24 21:52:01 EST
python-setuptools_scm-1.10.1-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-83ef8ccea4
Comment 11 Fedora Update System 2016-02-10 06:13:53 EST
python-setuptools_scm-1.10.1-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.