Bug 129202 - Can't mount 3 TB partition
Can't mount 3 TB partition
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
:
Depends On: 113898
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-04 20:04 EDT by Charles Tran
Modified: 2007-11-30 17:07 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 15:30:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Tran 2004-08-04 20:04:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031102

Description of problem:
Hardware:
Gateway 935s 1.4Ghz with 4GB ram 
2 aic-79xxx scsi , one onboard, one external,
3 internal Seagate SCSI 18G drives using onboard controller.
3Com 3c-589 GiG ethernet NIC
Promise Vtrak 15100 disk array 15 250GB WD sata drives.
The promise uses Busybox Linux and is attached to
Gateway via SCSI.

Creating a 14 Drive Raid 5 array with 1 Dedicated Hot Spare.

Cannot see over 2 Tb of the 3Tb array.  Splitting the array
into 2 7 drive Raid5 arrays works but it also uses multiple LUNS, 
I have this also figured out.

Per conversation with Promise Technical support a customer has
successfully mounted the entire 3.0 TB with Gentoo Linux and the 2.6
kernel using LBD support.. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create 14 drive (250GB)RAID 5 via Promise command line utility
initalize drives, enable over 2TB in firmware
2.fdisk the partition
3.Partition is less than 2 TB
    

Actual Results:  Partition is less than 2 Tb

Expected Results:  Partition over 3.0 Tb

Additional info:

FC2 does not even see the drive in Dmesg
Comment 1 Arjan van de Ven 2004-08-05 02:26:38 EDT
RHEL3 has a 1Tb/2Tb limit.

The 2.6 kernel series raises that limit (to like 16Tb). Can you file a
separate bug for the fedora problem please ?
Comment 2 Charles Tran 2004-08-05 10:41:24 EDT
That would have bee nice to know.. and should have been documented 
"somewhere" especially since at the Linux-Expo in San Francisco, 
everywhere there are presentations telling everyone about file 
partitions of over 10 TB..in fact a Redhat presentation at the Intel 
booth is touting 90 TB I think.. 
and mostly Redhat.. Does that sound like false advertising to you???

I only used FC2 as a test, we only run RHEL3, which begs the 
question, if the 2.6 kernel in FC2 doesn't work, then how much
different will the kernel be in RHEL 4?? Or will the 2.6 kernel
be available for RHEL3??

Tim Burke (From Boston Redhat) told me that the size limit will be 
fixed in U4 (RHAS 2.1 only went to U2)???  Can you confirm ???
Comment 3 Arjan van de Ven 2004-08-05 10:53:46 EDT
https://www.redhat.com/software/rhel/configuration/

has a clear limit for block devices.

I think you misunderstood Tim gravely; RHEL 2.1/AS cannot be fixed to
go > 2Tb.

FC2 should work (and it's the stream going towards RHEL4) so I'd be
very interested to hear why it doesn't work, but please separate that
into a seprate bugzilla.

Comment 4 Charles Tran 2004-08-05 11:19:17 EDT
a bit more clarification on Tim's comment..
".. the size limitation of ~2TB will be fixed in RHEL3 Update 4.... 
Update 3 which is due out this month does not address the size 
issue.."

I was surprised that there was going to be an UPdate 4 for RHEL3 
since RHAS 2.1 ONLY went to Update 2..  that was what I was trying to 
say in the last thread..sorry for the confusion..

Thanks for the link to the configuration page.. I see that the 
filesystem limit is 8TB.  
The limit on the SATA block device does not apply since the device 
is "seen" as a single SCSI device from RHEL3.. or currently in my 
case as 2 SCSI 1.5 TB partitions. ( I have 2 7-drive RAID5 on LUN 0 
and LUN 1.  Both of these partitions are formated as ext3 and 
mounted.. with No issues.. 
Comment 5 Arjan van de Ven 2004-08-05 11:22:18 EDT
Tim is at LW right now so I can't verify what he said/meant but I can
guarantee you that RHEL3 will remain to have the 1 / 2 Tb limit.


The limit is for block devices, which includes scsi luns but also
combined devices via MD raid...
Comment 6 Ernie Petrides 2004-08-05 19:38:57 EDT
In response to comment #4, RHEL 2.1 U5 is in beta right now,
along with RHEL 3 U3.
Comment 7 Rik van Riel 2004-08-05 20:44:22 EDT
We should definitely verify that RHEL4 can handle block devices larger
than 2TB. Unfortunately the 2.4 kernel isn't fixable in any safe way.

Note that 64 bit kernels should be able to address block devices
larger than 2TB, so AMD64, EM64T, IA64 and PPC64 kernels should be
able to address your block device. The 8TB filesystem limit is also
something that applies to 64 bit systems...
Comment 8 Tim Burke 2004-08-06 00:59:01 EDT
What I was saying at LW is that in RHEL3 U4 we are investigating
bumping the limit from 1TB to 2TB.  (Note this isn't yet a formal
commimitment as we haven't sorted out all the issues yet.)  
Comment 10 Charles Tran 2004-08-06 01:09:59 EDT
We only have the one machine that has this amount of
diskspace, but I split the raid5 into 2 1.5TB partitions..
This will suffice for our needs.. 

Since it doesn't look like the 2.4 kernel will probably not support
more than 2Tb then I can consider this issue closed for my 
purposes..

Thank you gentlemen..


Comment 11 Tim Burke 2004-08-26 15:30:47 EDT
Changing to closed/wontfix.  We're intending to up the limit to 2TB on
RHEL3, not 3TB.  To go above 2TB in a 2.4 kernel would require changes
which are far too invasive/risky.

Note You need to log in before you can comment on or make changes to this bug.