Bug 1292020 - quota: client gets IO error instead of disk quota exceed when the limit is exceeded
Summary: quota: client gets IO error instead of disk quota exceed when the limit is ex...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raghavendra G
QA Contact:
URL:
Whiteboard:
: 1208079 (view as bug list)
Depends On:
Blocks: qe_tracker_everglades 1208079 1224180 1332789 1332790
TreeView+ depends on / blocked
 
Reported: 2015-12-16 09:01 UTC by Vijaikumar Mallikarjuna
Modified: 2017-08-11 10:23 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1332789 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:22:15 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Vijaikumar Mallikarjuna 2015-12-16 09:01:32 UTC
Getting IO error instead of disk quota exceed when the limit is exceeded

# gluster volume create vol1 rh1:/var/opt/gluster/bricks/b1/dir
# gluster volume start vol1
# gluster volume quota vol1 enable
# gluster volume quota vol1 limit-usage / 1

# cd /mnt
# dd if=/dev/zero of=f1 bs=256k count=100
dd: writing `f1': Input/output error
dd: closing output file `f1': Input/output error

Comment 1 Vijay Bellur 2015-12-16 09:29:52 UTC
REVIEW: http://review.gluster.org/12978 (quota: success is returned when disk quota is exceeded) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Vijay Bellur 2015-12-16 09:44:06 UTC
REVIEW: http://review.gluster.org/12978 (quota: success is returned when disk quota is exceeded) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Vijay Bellur 2015-12-16 09:48:20 UTC
REVIEW: http://review.gluster.org/12978 (quota: success is returned when disk quota is exceeded) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 4 Vijay Bellur 2015-12-16 12:21:48 UTC
REVIEW: http://review.gluster.org/12981 (quota: success is returned when disk quota is exceeded) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 5 Vijay Bellur 2015-12-16 12:25:07 UTC
REVIEW: http://review.gluster.org/12981 (quota: success is returned when disk quota is exceeded) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 6 Vijay Bellur 2015-12-16 13:06:55 UTC
REVIEW: http://review.gluster.org/12981 (quota: set op_errno when a partial write done because of exceeding limit) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 7 Vijay Bellur 2016-02-12 12:11:49 UTC
REVIEW: http://review.gluster.org/13438 (performance/write-behind: guaranteed retry after a short write) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 8 Mike McCune 2016-03-28 23:44:20 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 9 Vijay Bellur 2016-04-07 02:46:39 UTC
REVIEW: http://review.gluster.org/13438 (performance/write-behind: guaranteed retry after a short write) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 10 Vijay Bellur 2016-05-04 03:27:05 UTC
REVIEW: http://review.gluster.org/13438 (performance/write-behind: guaranteed retry after a short write) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 11 Vijay Bellur 2016-05-04 12:01:49 UTC
COMMIT: http://review.gluster.org/13438 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit e3b2ed938a5dc8a72d1fe3d7ced341646d241ca4
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Fri Feb 12 17:17:30 2016 +0530

    performance/write-behind: guaranteed retry after a short write
    
    * Don't mark the request with a fake EIO after a short write.
    * retry the remaining buffer at least once before unwinding reply to
      application. This way we capture correct error from backend (ENOSPC,
      EDQUOT etc).
    
    Thanks to "Vijaikumar Mallikarjuna"<vmallika@redhat.com> for the test
    script.
    
    Change-Id: I73a18b39b661a7424db1a7855a980469a51da8f9
    BUG: 1292020
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/13438
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 15 Shyamsundar 2017-03-27 18:22:15 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 16 Ashish Pandey 2017-08-11 10:23:56 UTC
*** Bug 1208079 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.