Bug 1292024 - Strict dependency of optional package pam_krb5
Strict dependency of optional package pam_krb5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freeipa (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: IPA Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 04:24 EST by Lukas Slebodnik
Modified: 2016-11-19 16:01 EST (History)
9 users (show)

See Also:
Fixed In Version: freeipa-4.4.2-1.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-19 16:01:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Slebodnik 2015-12-16 04:24:47 EST
Description of problem:
freeipa-client is tested on modern distribution only with sssd.
I'm not aware os testing with pam_krb5 + nss-pam-ldapd even thought there is such option "--no-sssd"

[root@host ~]# ipa-client-install --help | tail -n 7
    -S, --no-sssd       Do not configure the client to use SSSD for
                        authentication
    --preserve-sssd     Preserve old SSSD configuration if possible

  uninstall options:
    --uninstall         uninstall an existing installation. The uninstall can
                        be run with --unattended option


Therefore it would be good to get rid of strict dependency on pam_krb5.
If you do not to remove it completely it would be good to change it to weak
dependencies. So pam_krb5 could be removed without removing package freeipa-client. 

Version-Release number of selected component (if applicable):
sh$ rpm -q freeipa-client
freeipa-client-4.2.3-2.fc23.x86_64

How reproducible:
Deterministic


Steps to Reproduce:
1. rpm -q --requires freeipa-client | grep pam_krb5
pam_krb5

Actual results:
Output contains "pam_krb5"

Expected results:
Output does not contain "pam_krb5"
Comment 1 Petr Vobornik 2015-12-17 06:37:08 EST
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5557
Comment 2 Lukas Slebodnik 2016-02-29 02:40:23 EST
Is there any progress on this one line change in fedora spec file?
s/Requires:/Recommends:/ or even better
s/Requires:/Suggests:/
Comment 4 Fedora Update System 2016-10-14 17:54:52 EDT
freeipa-4.4.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d89b3f7913
Comment 5 Fedora Update System 2016-11-19 16:01:32 EST
freeipa-4.4.2-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.