Bug 129203 - Determine some way to have package protected methods on domain objects
Determine some way to have package protected methods on domain objects
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/R&D (Show other bugs)
RHN Devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Fanny Augustin
:
Depends On:
Blocks: rhnMilestone1
  Show dependency treegraph
 
Reported: 2004-08-04 20:30 EDT by Mike McCune
Modified: 2007-04-18 13:10 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 18:36:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2004-08-04 20:30:03 EDT
Currently there are a set of methods on some of our domain objects
that we would like to *not* be in the public interface and only be
callable by the members of the package.

For instance:

com.redhat.rhn.domain.user.User.setRoles() 
com.redhat.rhn.domain.org.Org.getUserGroups()
com.redhat.rhn.domain.org.Org.setUserGroups()

we don't really want public consumers of these classes being able to
call these methods, but since all methods in an interface are public
we are stuck.
Comment 1 Jesus M. Rodriguez 2004-08-16 11:25:07 EDT
Maybe we can have two (2) interfaces.  One which is package protected
the other being public.  So all non-public methods should be in the
package protected interface.

public interface User {
    long getId();
    void setId(long id);
    ...
}

interface UserProtected {
    void setRoles(List roles);
    ...
}

Then UserImpl can implement both.  Only members of
com.redhat.rhn.domain.user can access UserProtected, while others can
only use User.

Note You need to log in before you can comment on or make changes to this bug.