Bug 1292038 - GtkWarning: when subscription-manager gui is launched
GtkWarning: when subscription-manager gui is launched
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.8
Unspecified Unspecified
high Severity low
: rc
: 6.8
Assigned To: Chris Rog
Shwetha Kallesh
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 05:06 EST by Rehana
Modified: 2016-05-10 16:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:38:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rehana 2015-12-16 05:06:22 EST
Description of problem:
When I start subscription-manager-gui I got  warnings on stdout.

Version-Release number of selected component (if applicable):
subscription management server: 2.0.10-1
subscription management rules: 5.19
subscription-manager: 1.16.6-1.el6
python-rhsm: 1.16.4-1.el6


How reproducible:
2/2

Steps to Reproduce:
1.open terminal, and launch subscription-manager-gui
2.
3.

Actual results:
[root@dhcp71-210 Desktop]# subscription-manager-gui
/usr/share/rhsm/subscription_manager/gui/widgets.py:108: GtkWarning: No object called: 0 0 396 39.600000000000001 356.40000000000003 396
  self.builder.add_from_file(self.gui_file_path)
/usr/share/rhsm/subscription_manager/gui/widgets.py:108: GtkWarning: No object called: 37 0 116 7.9000000000000004 71.100000000000009 79
  self.builder.add_from_file(self.gui_file_path)
/usr/share/rhsm/subscription_manager/gui/widgets.py:108: GtkWarning: No object called: 0 0 206 20.600000000000001 185.40000000000001 206
  self.builder.add_from_file(self.gui_file_path)

Expected results:
no warnings

Additional info:
Comment 1 Barnaby Court 2016-01-04 15:48:15 EST
There are likely other GTK warnings than the ones listed in the bug description. They should all be cleared.
Comment 2 Adrian Likins 2016-01-07 09:39:13 EST
My guess would be some of the old glade files need GtkAdjustments added
 (the "0 0 206 20.600000000000001 185.40000000000001 206" args look like args for GtkAdjustments)
Comment 3 Chris Rog 2016-01-14 13:56:14 EST
commit f43cf72547749049dd97a42d3d2e9d60210f85c2
Author: crog <crog@localhost.localdomain>
Date:   Mon Jan 11 13:50:33 2016 -0500

    1292038: Changed adjustments to GtkAdjustment objects
Comment 4 Chris Snyder 2016-01-19 13:53:14 EST
This will be included in the next build (as such moving to modified).
Comment 6 Shwetha Kallesh 2016-01-20 06:07:10 EST
Marking verified as I see no warnings

[root@hp-dl320egen8-01 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.14-1
subscription management rules: 5.15.1
subscription-manager: 1.16.8-1.el6
python-rhsm: 1.16.6-1.el6


[root@hp-dl320egen8-01 ~]# subscription-manager-gui
Comment 8 errata-xmlrpc 2016-05-10 16:38:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0797.html

Note You need to log in before you can comment on or make changes to this bug.