Bug 1292053 - The matcher value is not hidden while creating matcher.
The matcher value is not hidden while creating matcher.
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: orabin
Jitendra Yejare
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1278718
  Show dependency treegraph
 
Reported: 2015-12-16 05:55 EST by Jitendra Yejare
Modified: 2016-07-27 05:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:00:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot Attached. (257.22 KB, image/png)
2015-12-16 05:55 EST, Jitendra Yejare
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12843 None None None 2016-04-22 11:05 EDT

  None (edit)
Description Jitendra Yejare 2015-12-16 05:55:15 EST
Created attachment 1106369 [details]
Screenshot Attached.

Description of problem:
The matcher value in Smart Class Parameter and Smart Variable is not hidden while creating matcher and 'Hidden Value' checkbox is checked. It gets hidden only after hitting the submit button to save the changes.

Version-Release number of selected component (if applicable):
foreman-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. From Config->Smart Class Parameters->parameter, Override the parameter Default value.(By checking Override checkbox)
2. Check 'Hidden Value' checkbox to hide the default value.
3. Create a new matcher for any available attribute.
4. While creating the matcher observe the value is hidden.

Actual results:
The matcher value is not hidden while creating matcher.
After Submit, the value gets hidden for matcher.

Expected results:
The matcher value should be hidden while creating itself.

Additional info:
Comment 3 Bryan Kearney 2016-01-20 10:03:10 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/12843 has been closed
-------------
Ori Rabin
Applied in changeset commit:505c259f03945298a83718f456b8f2b983360f45.
Comment 4 Jitendra Yejare 2016-01-27 07:32:40 EST
Verified this issue in Upstream.

Build: foreman-1.11.0-0.develop.201601251557git59dc77b.el6.noarch
Comment 6 Jitendra Yejare 2016-03-22 05:27:44 EDT
Verified this bug in Sat 6.2 snap 4,

The issue is no more reproducible.

I see that the matcher value is shown while creating matcher as hidden when 'Hidden Value' checkbox is enabled.

So changing the state to Verified.
Comment 9 errata-xmlrpc 2016-07-27 05:00:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.