Bug 129211 - VTE does not handle indic composite characters and ligatures
Summary: VTE does not handle indic composite characters and ligatures
Status: CLOSED DUPLICATE of bug 147025
Alias: None
Product: Fedora
Classification: Fedora
Component: vte   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: Indic
TreeView+ depends on / blocked
 
Reported: 2004-08-05 02:54 UTC by Jatin Nansi
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jatin Nansi 2004-08-05 02:54:43 UTC
Description of problem:
Composites and ligatures in indic text are not rendered correctly in vte. 

Version-Release number of selected component (if applicable):
0.11.10-5.1

How reproducible:
every time

Steps to Reproduce:
1.  wget http://bbc.co.uk/hindi/index.html
2.  cat index.html
3.  gedit index.html, compare hindi text with text catted above
  
Actual results:
gedit renders hindi correctly, but vte does not.

Expected results:
vte renders hindi correctly.

Additional info:
We are aware that incorporating pango support into vte will result in
a performance hit. So if its presently not possible to do the indic
text processing for vte, can we have the default english monospace
font in the indic locales? As currently the display of even the
english text in vte in indic locales is not proper since the indic
font does not have monospaced glyphs.

Comment 1 Jatin Nansi 2004-08-12 02:13:37 UTC
To test, you may use the Gargi.ttf font available in this rpm: 
http://bob.brisbane.redhat.com/~jnansi/pkgs/ttfonts-hi-1-1.noarch.rpm

Comment 2 Leon Ho 2004-08-26 02:29:30 UTC
Nalin, I hope you don't mind if I cc' you in here.

Comment 5 Leon Ho 2005-02-09 16:30:07 UTC
We can tracking this through feature #147025. Closing this out.

Comment 6 Leon Ho 2005-02-09 16:30:29 UTC

*** This bug has been marked as a duplicate of 147025 ***

Comment 7 Red Hat Bugzilla 2006-02-21 19:04:57 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.