Bug 1292129 - [RHEV clone] Live merge: Engine must refresh resized volume on HSM prior to starting merge
[RHEV clone] Live merge: Engine must refresh resized volume on HSM prior to s...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.7
Unspecified Unspecified
unspecified Severity high
: ovirt-3.5.7
: 3.5.7
Assigned To: Greg Padgett
Aharon Canan
storage
: ZStream
Depends On: 1274323
Blocks: 1232481 1291569
  Show dependency treegraph
 
Reported: 2015-12-16 09:38 EST by Allon Mureinik
Modified: 2016-04-17 20:28 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1274323
Environment:
Last Closed: 2016-01-12 15:41:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1488453 None None None 2016-04-17 20:28 EDT
oVirt gerrit 47671 None None None 2015-12-16 09:38 EST
oVirt gerrit 50470 None None None 2015-12-16 09:38 EST
oVirt gerrit 50474 None None None 2015-12-16 09:38 EST

  None (edit)
Description Allon Mureinik 2015-12-16 09:38:39 EST
+++ This bug was initially created as a clone of Bug #1274323 +++

Description of problem:

If a drive was enlarged after creation of a snapshot then the volume associated with the snapshot will be smaller than the currently active volume.  If the snapshot volume is also on preallocated block storage then engine needs to manually enlarge the snapshot volume prior to starting a live merge.

Today, engine issues the extendVolumeSize call to SPM but it does not notify the host running the VM (HSM host) that the volume has been resized.  This means that when a VM is running on a non-SPM host the resize won't be picked up by qemu and the merge will fail.


Version-Release number of selected component (if applicable):
ovirt-engine-4.0.0-0.0.master.20151020161541.git37557f3.el7.centos.noarch

How reproducible:
Always

Steps to Reproduce:
1. Start a VM on a non-SPM host with a preallocated block disk
2. Create a snapshot involving the disk
3. Enlarge the disk by 1GB
4. Delete the snapshot

Actual results:
The merge fails with an error like the following on the HSM host:

libvirtError: internal error: unable to execute QEMU command 'block-commit': Top image /rhev/data-center/108151fa-1c40-4ee3-bae0-d91d0e56f44d/2276ca67-cdff-4bde-b437-446fc2e92a46/images/65ade35f-deed-4e0d-8a73-7c98c80fb661/b97c3c80-f781-4b51-bb79-5929fd9f3cf8 is larger than base image /rhev/data-center/108151fa-1c40-4ee3-bae0-d91d0e56f44d/2276ca67-cdff-4bde-b437-446fc2e92a46/images/65ade35f-deed-4e0d-8a73-7c98c80fb661/71bc1e19-e392-4121-9c2f-896d7402db22, and resize of base image failed: Invalid argument

Expected results:

The snapshot should be removed successfully.

Additional info:

--- Additional comment from Adam Litke on 2015-10-22 16:36 IDT ---



--- Additional comment from Adam Litke on 2015-10-22 16:37 IDT ---



--- Additional comment from Adam Litke on 2015-10-22 16:37 IDT ---



--- Additional comment from Adam Litke on 2015-10-22 16:38:46 IDT ---

I believe the proper way to fix this is for engine to issue a diskSizeExtend to the HSM host as discussed in the Feature Page for online disk resize:

http://www.ovirt.org/Features/Online_Virtual_Drive_Resize#Detailed_Description

--- Additional comment from Yaniv Dary on 2015-10-29 14:51:23 IST ---

In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 1 Eyal Edri 2015-12-17 08:33:23 EST
included in the build.
Comment 2 Aharon Canan 2015-12-27 06:35:01 EST
Verified using the following versions:
---------------------------------------
rhevm-3.5.7-0.1.el6ev.noarch - running on Rhel6.7
vdsm-4.16.31-1.el7ev.x86_64 - running on Rhel7.2

Scenario 1:
----------------
1. Create a VM with 1gb preallocated disk on a block-based domain.
2. Create a snapshot.
3. Extend the disk to 2gb.
4. Start the VM on HSM.
5. Delete the snapshot

Scenario 2:
--------------------
1) Create a VM with 1gb preallocated disk in a block-based domain.
2) Create a snapshot.
3) Create a second snapshot.
4) Extend the disk to 2gb.
5) Start the VM on HSM.
6) Delete the second snapshot
Comment 5 errata-xmlrpc 2016-01-12 15:41:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0029.html

Note You need to log in before you can comment on or make changes to this bug.