Bug 1292151 - rhnpush: missing required package on RHEL5
rhnpush: missing required package on RHEL5
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Client (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gennadii Altukhov
Pavel Studeník
:
Depends On:
Blocks: sat580-low
  Show dependency treegraph
 
Reported: 2015-12-16 10:18 EST by Pavel Studeník
Modified: 2017-06-21 08:07 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhnpush-5.5.89-9-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-21 08:07:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for spec file of rhnpush package (454 bytes, patch)
2016-02-16 04:27 EST, Gennadii Altukhov
no flags Details | Diff

  None (edit)
Description Pavel Studeník 2015-12-16 10:18:13 EST
Description of problem:
I took client without satellite or proxy, registered it and installed rhnpush to this clean system. When I tried to run rhnpush I received following error:

# rhnpush  --help
Unable to load module rhnpush
No module named Crypto.Hash

Version-Release number of selected component (if applicable):
rhnpush-5.5.81-9.el5sat

How reproducible:
always on RHEL5

Steps to Reproduce:
1. install rhnpush from rhn-tools-rhel-x86_64-server-5
2. run rhnpush

Actual results:
installed rhnpush doesn't work

Expected results:
we need to installed package python-hashlib

Problem is in file /usr/share/rhn/rhnpush_libs/checksum.py
Comment 1 Tomas Lestach 2016-01-27 05:31:40 EST
After I installed rhnpush-5.5.81-9.el5sat on RHEL5, I'm getting:

# rhnpush 
Unable to load module rhnpush
No module named Crypto.Hash
Comment 2 Gennadii Altukhov 2016-02-15 05:58:45 EST
Taking...
Comment 3 Gennadii Altukhov 2016-02-16 04:27 EST
Created attachment 1127544 [details]
patch for spec file of rhnpush package
Comment 4 Gennadii Altukhov 2016-02-16 04:33:01 EST
There is no problem in Spacewalk package of rhnpush. rhnpush depends on spacewalk-backend-libs, which depends on python-hashlib ('epel' repo).

For Satellite there are no problems for RHEL 6 and 7, since installed package 'python-libs' contains module hashlib (/usr/lib64/python2.6/hashlib.py) to work with hash functions. In code of 'rhnpush_lib' we're trying to import hashlib first.

For Satellite package of rhnpush RHEL 5, I have added a dependensy on python-hashlib (this package is contained in 'Red Hat Network Tools for RHEL' repo), please, see at attached patch.
Comment 7 Pavel Studeník 2017-05-10 08:07:47 EDT
Verified rhnpush-5.5.89-20.el5sat

>> yum install rhnpush -y
Installing:
 rhnpush
Installing for dependencies:
 python-hashlib
 spacewalk-backend-libs
 spacewalk-usix

Note You need to log in before you can comment on or make changes to this bug.