Bug 1292161 - [RFE] Allow openshift gear restorer to ignore certain user agents
[RFE] Allow openshift gear restorer to ignore certain user agents
Status: CLOSED DEFERRED
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Timothy Williams
DeShuai Ma
: Reopened
Depends On:
Blocks: 1277547
  Show dependency treegraph
 
Reported: 2015-12-16 10:34 EST by Andy Grimm
Modified: 2016-11-07 22:48 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-20 10:23:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Grimm 2015-12-16 10:34:40 EST
When OpenShift Online is crawled by a search engine or survey bot, we do not want to have such actions unidle gears, as this can significantly change our capacity needs.  Currently, we have a modified version of restorer.php in place which does this, but the regex is hard-coded.  We'll need to do some additional work to allow this to be configurable.  (Jhon Honce had the suggestion of using an environment variable passed through httpd, to avoid having to read a file every time this script runs.)
Comment 2 Miciah Dashiel Butler Masters 2015-12-18 15:45:44 EST
Because this RFE is for OpenShift Online v2 and because you have a workaround, we don't see a need to prioritise this RFE for OpenShift Origin v2.  However, we do plan to implement the feature in OpenShift Origin v3 (<https://trello.com/c/GV5xCQVL/9-5-unidle-from-routing-layer-traffic-ingress-idling>).
Comment 3 Andy Grimm 2016-01-05 17:08:11 EST
Miciah, I think you misunderstand.  Our workaround specifically involves overriding a packaged file, and the next update will break us.
Comment 4 John W. Lamb 2016-01-18 11:32:57 EST
per discussion with agrimm, perhaps this can be implemented in the Apache config?
Comment 5 John W. Lamb 2016-01-29 16:54:58 EST
Andy, how long have you been running this workaround?
Comment 7 Andy Grimm 2016-09-19 16:53:46 EDT
Removing needinfo on this.  Our restorer has become even more highly customized over the past 8 months, but at this point we also haven't done any releases in 2016, so I'm not all that worried about this.  we just have to immediately run puppet after any openshift package updates.
Comment 8 Timothy Williams 2016-09-20 10:23:33 EDT
Thanks for the follow up Andy.

I'm going to close this out then. I apologize that we never got around to this.

Note You need to log in before you can comment on or make changes to this bug.