Bug 1292165 - Tenant and project name unique on parent tenant level only
Tenant and project name unique on parent tenant level only
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Milan Zázrivec
Pavol Kotvan
tenant_cfme:ui
:
Depends On:
Blocks: 1292471
  Show dependency treegraph
 
Reported: 2015-12-16 10:51 EST by Pavol Kotvan
Modified: 2016-06-29 11:21 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1292471 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:21:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tenant tree with same child tenant names (152.82 KB, image/png)
2015-12-16 10:51 EST, Pavol Kotvan
no flags Details

  None (edit)
Description Pavol Kotvan 2015-12-16 10:51:45 EST
Created attachment 1106487 [details]
Tenant tree with same child tenant names

Description of problem:
Names of tenants are unique on parent tenant level but can have the same name in child tenants. This might be confusing for end users, because you see the same tenant name several times and you are not able identify which name is which part of tenant/child-tenant tree. See attached screenshot.

Version-Release number of selected component (if applicable):
5.5.0.13

How reproducible:
always

Steps to Reproduce:
1. As super administrator create tenant1
2. Create multiple child tenants tenant1_sub1 under tenant1. It is allowed to use tenant1_sub1 several times in nested tree.
3. Create new parent tenant (Child of My Company tenant) with name tenant1_sub1
4. Navigate to groups, edit existing group and open Project/tenant dropdown list

Actual results:
When modifying group, there are multiple items with same name in Project/Tenant dropdwon list. See attached screenshot.

Expected results:
1. Tenant/Project name is unique in whole CFME UI
2. In Project/tenant dropdown items will be listed as tree (e.g. My Company/tenant1/tenant1_sub1/tenant1_sub1/tenant1_sub1)

Additional info:
Comment 2 Milan Zázrivec 2016-01-11 08:30:19 EST
https://github.com/ManageIQ/manageiq/pull/6122
Comment 3 CFME Bot 2016-01-18 17:21:00 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/08a4716920e959c901120d7adff20ef9cc533337

commit 08a4716920e959c901120d7adff20ef9cc533337
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Mon Jan 11 14:23:33 2016 +0100
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Mon Jan 18 20:22:15 2016 +0100

    Add all tenant ancestors to group creation page
    
    This is to avoid ambiguity in case there are more
    tenants with the same name.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1292165

 app/controllers/ops_controller/ops_rbac.rb | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)
Comment 5 CFME Bot 2016-01-19 22:43:20 EST
Detected commit referencing this ticket while ticket status is MODIFIED.
Comment 9 errata-xmlrpc 2016-06-29 11:21:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.